CVE-2019-20788
CVE-2019-20788
This page contains facts from public vulnerability sources. Check the original advisory before updating.
libvncclient/cursor.c in LibVNCServer through 0.9.12 has a HandleCursorShape integer overflow and heap-based buffer overflow via a large height or width value. NOTE: this may overlap CVE-2019-15690.
CVSS 9.8 · Critical · EPSS 2.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
libvncserver Debian:12
- Affected ranges
- ECOSYSTEM: < 0.9.12+dfsg-9
Update to 0.9.12+dfsg-9
libvncserver Debian:13
- Affected ranges
- ECOSYSTEM: < 0.9.12+dfsg-9
Update to 0.9.12+dfsg-9
libvncserver Debian:14
- Affected ranges
- ECOSYSTEM: < 0.9.12+dfsg-9
Update to 0.9.12+dfsg-9
x11vnc Ubuntu:14.04:LTS
- Versions
- 0.9.13-1.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libvncserver Ubuntu:16.04:LTS
- Versions
- 0.9.10+dfsg-3
- 0.9.10+dfsg-3build1
- 0.9.10+dfsg-3ubuntu0.16.04.1
- 0.9.10+dfsg-3ubuntu0.16.04.2
- 0.9.10+dfsg-3ubuntu0.16.04.3
- Affected ranges
- ECOSYSTEM: < 0.9.10+dfsg-3ubuntu0.16.04.4
Update to 0.9.10+dfsg-3ubuntu0.16.04.4
libvncserver Ubuntu:18.04:LTS
- Versions
- 0.9.11+dfsg-1
- 0.9.11+dfsg-1ubuntu1
- 0.9.11+dfsg-1ubuntu1.1
- Affected ranges
- ECOSYSTEM: < 0.9.11+dfsg-1ubuntu1.2
Update to 0.9.11+dfsg-1ubuntu1.2
Original sources
- https://github.com/LibVNC/libvncserver/commit/54220248886b5001fbbb9fa73c4e1a2cb9413fed
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00027.html
- https://usn.ubuntu.com/4407-1/
- https://securitylab.github.com/advisories/GHSL-2020-064-libvnc-libvncclient
- https://cert-portal.siemens.com/productcert/pdf/ssa-390195.pdf
- https://nvd.nist.gov/vuln/detail/CVE-2019-20788