CVE-2019-2602
CVE-2019-2602
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: Libraries). Supported versions that are affected are Java SE: 7u211, 8u202, 11.0.2 and 12; Java SE Embedded: 8u201. Easily exploitable vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, Java SE Embedded. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of Java SE, Java SE Embedded. Note: This vulnerability can only be exploited by supplying data to APIs in the specified Component without using Untrusted Java Web Start applications or Untrusted Java applets, such as through a web service. CVSS 3.0 Base Score 7.5 (Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H).
CVSS 7.5 · High · EPSS 4.4% · Fix available
- Published
- Updated
Stack: system · applications
Affected products and versions
java
- Versions
- Java SE: 7u211, 8u202, 11.0.2, 12: Affected
- Java SE Embedded: 8u201: Affected
No fix published
openjdk-11 Debian:11
- Affected ranges
- ECOSYSTEM: < 11.0.3+7-1
Update to 11.0.3+7-1
openjdk-8 Ubuntu:16.04:LTS
- Versions
- 8u66-b01-5
- 8u72-b05-1ubuntu1
- 8u72-b05-5
- 8u72-b05-6
- 8u72-b15-1
- 8u72-b15-2ubuntu1
- 8u72-b15-2ubuntu3
- 8u72-b15-3ubuntu1
- 8u77-b03-1ubuntu2
- 8u77-b03-3ubuntu1
- 8u77-b03-3ubuntu2
- 8u77-b03-3ubuntu3
- 8u91-b14-0ubuntu4~16.04.1
- 8u91-b14-3ubuntu1~16.04.1
- 8u111-b14-2ubuntu0.16.04.2
- 8u121-b13-0ubuntu1.16.04.2
- 8u131-b11-0ubuntu1.16.04.2
- 8u131-b11-2ubuntu1.16.04.2
- 8u131-b11-2ubuntu1.16.04.3
- 8u151-b12-0ubuntu0.16.04.2
- 8u162-b12-0ubuntu0.16.04.2
- 8u171-b11-0ubuntu0.16.04.1
- 8u181-b13-0ubuntu0.16.04.1
- 8u181-b13-1ubuntu0.16.04.1
- 8u191-b12-0ubuntu0.16.04.1
- 8u191-b12-2ubuntu0.16.04.1
- Affected ranges
- ECOSYSTEM: < 8u212-b03-0ubuntu1.16.04.1
Update to 8u212-b03-0ubuntu1.16.04.1
openjdk-8 Ubuntu:18.04:LTS
- Versions
- 8u144-b01-2
- 8u151-b12-1
- 8u162-b12-1
- 8u171-b11-0ubuntu0.18.04.1
- 8u181-b13-0ubuntu0.18.04.1
- 8u181-b13-1ubuntu0.18.04.1
- 8u191-b12-0ubuntu0.18.04.1
- 8u191-b12-2ubuntu0.18.04.1
- Affected ranges
- ECOSYSTEM: < 8u212-b03-0ubuntu1.18.04.1
Update to 8u212-b03-0ubuntu1.18.04.1
openjdk-lts Ubuntu:18.04:LTS
- Versions
- 9.0.4+12-2ubuntu4
- 9.0.4+12-4ubuntu1
- 10~46-4ubuntu1
- 10~46-5ubuntu1
- 10.0.1+10-1ubuntu2
- 10.0.1+10-3ubuntu1
- 10.0.2+13-1ubuntu0.18.04.1
- 10.0.2+13-1ubuntu0.18.04.2
- 10.0.2+13-1ubuntu0.18.04.3
- 10.0.2+13-1ubuntu0.18.04.4
- 11.0.2+9-3ubuntu1~18.04.3
- Affected ranges
- ECOSYSTEM: < 11.0.3+7-1ubuntu2~18.04.1
Update to 11.0.3+7-1ubuntu2~18.04.1
Original sources
- http://www.oracle.com/technetwork/security-advisory/cpuapr2019-5072813.html
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00007.html
- https://access.redhat.com/errata/RHBA-2019:0959
- https://lists.debian.org/debian-lts-announce/2019/05/msg00011.html
- https://access.redhat.com/errata/RHSA-2019:1146
- https://usn.ubuntu.com/3975-1/
- https://access.redhat.com/errata/RHSA-2019:1164
- https://access.redhat.com/errata/RHSA-2019:1163
- https://access.redhat.com/errata/RHSA-2019:1165
- https://access.redhat.com/errata/RHSA-2019:1166
- https://access.redhat.com/errata/RHSA-2019:1238
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00059.html
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00058.html
- https://www.debian.org/security/2019/dsa-4453
- https://seclists.org/bugtraq/2019/May/75
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00013.html
- https://access.redhat.com/errata/RHSA-2019:1325
- https://access.redhat.com/errata/RHSA-2019:1518
- https://kc.mcafee.com/corporate/index?page=content&id=SB10285
- https://security.gentoo.org/glsa/201908-10
- https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbst03959en_us
- https://nvd.nist.gov/vuln/detail/CVE-2019-2602