p PatchFirst

CVE-2019-2738

CVE-2019-2738

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server : Compiling). Supported versions that are affected are 5.6.44 and prior, 5.7.26 and prior and 8.0.16 and prior. Difficult to exploit vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized read access to a subset of MySQL Server accessible data. CVSS 3.0 Base Score 3.1 (Confidentiality impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N).

CVSS 3.1 · Low · EPSS 1.6% · Fix available

Published
Updated

Stack: system · database

Affected products and versions

  • mysql

    Versions
    • 5.6.44 and prior: Affected
    • 5.7.26 and prior: Affected
    • 8.0.16 and prior: Affected

    No fix published

  • mysql-5.5 Ubuntu:14.04:LTS

    Versions
    • 5.5.32-0ubuntu7
    • 5.5.34-0ubuntu1
    • 5.5.34-0ubuntu2
    • 5.5.35-0ubuntu1
    • 5.5.35+dfsg-1ubuntu1
    • 5.5.37-0ubuntu0.14.04.1
    • 5.5.38-0ubuntu0.14.04.1
    • 5.5.40-0ubuntu0.14.04.1
    • 5.5.41-0ubuntu0.14.04.1
    • 5.5.43-0ubuntu0.14.04.1
    • 5.5.44-0ubuntu0.14.04.1
    • 5.5.46-0ubuntu0.14.04.2
    • 5.5.47-0ubuntu0.14.04.1
    • 5.5.49-0ubuntu0.14.04.1
    • 5.5.50-0ubuntu0.14.04.1
    • 5.5.52-0ubuntu0.14.04.1
    • 5.5.53-0ubuntu0.14.04.1
    • 5.5.54-0ubuntu0.14.04.1
    • 5.5.55-0ubuntu0.14.04.1
    • 5.5.57-0ubuntu0.14.04.1
    • 5.5.58-0ubuntu0.14.04.1
    • 5.5.59-0ubuntu0.14.04.1
    • 5.5.60-0ubuntu0.14.04.1
    • 5.5.61-0ubuntu0.14.04.1
    • 5.5.62-0ubuntu0.14.04.1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • mysql-5.7 Ubuntu:16.04:LTS

    Versions
    • 5.7.11-0ubuntu4
    • 5.7.11-0ubuntu5
    • 5.7.11-0ubuntu6
    • 5.7.12-0ubuntu1
    • 5.7.12-0ubuntu1.1
    • 5.7.13-0ubuntu0.16.04.2
    • 5.7.15-0ubuntu0.16.04.1
    • 5.7.16-0ubuntu0.16.04.1
    • 5.7.17-0ubuntu0.16.04.1
    • 5.7.17-0ubuntu0.16.04.2
    • 5.7.18-0ubuntu0.16.04.1
    • 5.7.19-0ubuntu0.16.04.1
    • 5.7.20-0ubuntu0.16.04.1
    • 5.7.21-0ubuntu0.16.04.1
    • 5.7.22-0ubuntu0.16.04.1
    • 5.7.23-0ubuntu0.16.04.1
    • 5.7.24-0ubuntu0.16.04.1
    • 5.7.25-0ubuntu0.16.04.2
    • 5.7.26-0ubuntu0.16.04.1
    Affected ranges
    • ECOSYSTEM: < 5.7.27-0ubuntu0.16.04.1

    Update to 5.7.27-0ubuntu0.16.04.1

  • percona-server-5.6 Ubuntu:16.04:LTS

    Versions
    • 5.6.22-rel71.0-0ubuntu2
    • 5.6.22-rel71.0-0ubuntu4
    • 5.6.22-rel71.0-0ubuntu4.1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • percona-xtradb-cluster-5.6 Ubuntu:16.04:LTS

    Versions
    • 5.6.21-25.8-0ubuntu2
    • 5.6.21-25.8-0ubuntu3
    • 5.6.21-25.8-0ubuntu3.1
    • 5.6.21-25.8-0ubuntu3.2
    • 5.6.34-26.19-0ubuntu0.16.04.1
    • 5.6.34-26.19-0ubuntu0.16.04.2
    • 5.6.37-26.21-0ubuntu0.16.04.1
    • 5.6.37-26.21-0ubuntu0.16.04.2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • mysql-5.7 Ubuntu:18.04:LTS

    Versions
    • 5.7.19-0ubuntu1
    • 5.7.20-0ubuntu0.17.10.1
    • 5.7.20-1ubuntu1
    • 5.7.21-1ubuntu1
    • 5.7.22-0ubuntu18.04.1
    • 5.7.23-0ubuntu0.18.04.1
    • 5.7.24-0ubuntu0.18.04.1
    • 5.7.25-0ubuntu0.18.04.2
    • 5.7.26-0ubuntu0.18.04.1
    Affected ranges
    • ECOSYSTEM: < 5.7.27-0ubuntu0.18.04.1

    Update to 5.7.27-0ubuntu0.18.04.1

Original sources

Check your server →