CVE-2019-3556
CVE-2019-3556
This page contains facts from public vulnerability sources. Check the original advisory before updating.
HHVM supports the use of an "admin" server which accepts administrative requests over HTTP. One of those request handlers, dump-pcre-cache, can be used to output cached regular expressions from the current execution context into a file. The handler takes a parameter which specifies where on the filesystem to write this data. The parameter is not validated, allowing a malicious user to overwrite arbitrary files where the user running HHVM has write access. This issue affects HHVM versions prior to 4.56.2, all versions between 4.57.0 and 4.78.0, as well as 4.79.0, 4.80.0, 4.81.0, 4.82.0, and 4.83.0.
CVSS 8.1 · High · EPSS 1.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
hhvm
- Versions
- ≥ 4.83.1, < unspecified: Not affected (custom)
- ≥ 4.83.0, < unspecified: Affected (custom)
- ≥ 4.82.1, < unspecified: Not affected (custom)
- ≥ 4.82.0, < unspecified: Affected (custom)
- ≥ 4.81.1, < unspecified: Not affected (custom)
- ≥ 4.81.0, < unspecified: Affected (custom)
- ≥ 4.80.1, < unspecified: Not affected (custom)
- ≥ 4.80.0, < unspecified: Affected (custom)
- ≥ 4.79.1, < unspecified: Not affected (custom)
- ≥ 4.79.0, < unspecified: Affected (custom)
- ≥ 4.78.1, < unspecified: Not affected (custom)
- ≥ 4.57.0, < unspecified: Affected (custom)
- ≥ 4.56.2, < unspecified: Not affected (custom)
- ≥ unspecified, < 4.56.2: Affected (custom)
Update to 4.56.2
hhvm Ubuntu:16.04:LTS
- Versions
- 3.11.0+dfsg-1
- 3.11.1+dfsg-1
- 3.11.1+dfsg-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
hhvm Ubuntu:18.04:LTS
- Versions
- 3.21.0+dfsg-2
- 3.21.0+dfsg-2build1
- 3.21.0+dfsg-2build2
- 3.21.0+dfsg-2build3
- 3.21.0+dfsg-2ubuntu2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published