CVE-2019-3808
CVE-2019-3808
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A flaw was found in Moodle versions 3.6 to 3.6.1, 3.5 to 3.5.3, 3.4 to 3.4.6, 3.1 to 3.1.15 and earlier unsupported versions. The 'manage groups' capability did not have the 'XSS risk' flag assigned to it, but does have that access in certain places. Note that the capability is intended for use by trusted users, and is only assigned to teachers and managers by default.
CVSS 4.3 · Medium · EPSS 1.2% · Fix available
- Published
- Updated
Affected products and versions
moodle
- Versions
- 3.6.2: Affected
- 3.5.4: Affected
- 3.4.7: Affected
- 3.1.16: Affected
No fix published
moodle/moodle Packagist
- Versions
- v3.6.0
- v3.6.1
- Affected ranges
- ECOSYSTEM: ≥ 3.6.0, < 3.6.2
Update to 3.6.2
moodle/moodle Packagist
- Versions
- v3.5.0
- v3.5.1
- v3.5.2
- v3.5.3
- Affected ranges
- ECOSYSTEM: ≥ 3.5.0, < 3.5.4
Update to 3.5.4
moodle/moodle Packagist
- Versions
- v3.2.0
- v3.2.1
- v3.2.2
- v3.2.3
- v3.2.4
- v3.2.5
- v3.2.6
- v3.2.7
- v3.2.8
- v3.2.9
- v3.3.0
- v3.3.0-beta
- v3.3.0-rc1
- v3.3.0-rc2
- v3.3.0-rc3
- v3.3.1
- v3.3.2
- v3.3.3
- v3.3.4
- v3.3.5
- v3.3.6
- v3.3.7
- v3.3.8
- v3.3.9
- v3.4.0
- v3.4.0-beta
- v3.4.0-rc1
- v3.4.0-rc2
- v3.4.0-rc3
- v3.4.1
- v3.4.2
- v3.4.3
- v3.4.4
- v3.4.5
- v3.4.6
- Affected ranges
- ECOSYSTEM: ≥ 3.2.0, < 3.4.7
Update to 3.4.7
moodle/moodle Packagist
- Versions
- v2.3.10
- v2.3.11
- v2.3.4
- v2.3.5
- v2.3.6
- v2.3.7
- v2.3.8
- v2.3.9
- v2.4.0
- v2.4.0-rc1
- v2.4.1
- v2.4.10
- v2.4.11
- v2.4.2
- v2.4.3
- v2.4.4
- v2.4.5
- v2.4.6
- v2.4.7
- v2.4.8
- v2.4.9
- v2.5.0
- v2.5.0-beta
- v2.5.0-rc1
- v2.5.1
- v2.5.2
- v2.5.3
- v2.5.4
- v2.5.5
- v2.5.6
- v2.5.7
- v2.5.8
- v2.5.9
- v2.6.0
- v2.6.0-beta
- v2.6.0-rc1
- v2.6.1
- v2.6.10
- v2.6.11
- v2.6.2
- v2.6.3
- v2.6.4
- v2.6.5
- v2.6.6
- v2.6.7
- v2.6.8
- v2.6.9
- v2.7.0
- v2.7.0-beta
- v2.7.0-rc1
- v2.7.0-rc2
- v2.7.1
- v2.7.10
- v2.7.11
- v2.7.12
- v2.7.13
- v2.7.14
- v2.7.15
- v2.7.16
- v2.7.17
- v2.7.18
- v2.7.19
- v2.7.2
- v2.7.20
- v2.7.3
- v2.7.4
- v2.7.5
- v2.7.6
- v2.7.7
- v2.7.8
- v2.7.9
- v2.8.0
- v2.8.0-beta
- v2.8.0-rc1
- v2.8.0-rc2
- v2.8.1
- v2.8.10
- v2.8.11
- v2.8.12
- v2.8.2
- v2.8.3
- v2.8.4
- v2.8.5
- v2.8.6
- v2.8.7
- v2.8.8
- v2.8.9
- v2.9.0
- v2.9.0-beta
- v2.9.0-rc1
- v2.9.0-rc2
- v2.9.1
- v2.9.2
- v2.9.3
- v2.9.4
- v2.9.5
- v2.9.6
- v2.9.7
- v2.9.8
- v2.9.9
- v3.0.0
- v3.0.0-beta
- v3.0.0-rc1
- v3.0.0-rc2
- v3.0.0-rc3
- v3.0.0-rc4
- v3.0.1
- v3.0.10
- v3.0.2
- v3.0.3
- v3.0.4
- v3.0.5
- v3.0.6
- v3.0.7
- v3.0.8
- v3.0.9
- v3.1.0
- v3.1.0-beta
- v3.1.0-rc1
- v3.1.0-rc2
- v3.1.1
- v3.1.10
- v3.1.11
- v3.1.12
- v3.1.13
- v3.1.14
- v3.1.15
- v3.1.2
- v3.1.3
- v3.1.4
- v3.1.5
- v3.1.6
- v3.1.7
- v3.1.8
- v3.1.9
- Affected ranges
- ECOSYSTEM: < 3.1.16
Update to 3.1.16
moodle Ubuntu:Pro:16.04:LTS
- Versions
- 2.7.9+dfsg-1
- 2.7.10+dfsg-1
- 2.7.11+dfsg-1
- 2.7.11+dfsg-2
- 2.7.12+dfsg-1
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
moodle Ubuntu:Pro:18.04:LTS
- Versions
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published