p PatchFirst

CVE-2019-3840

CVE-2019-3840

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A NULL pointer dereference flaw was discovered in libvirt before version 5.0.0 in the way it gets interface information through the QEMU agent. An attacker in a guest VM can use this flaw to crash libvirtd and cause a denial of service.

CVSS 5.8 · Medium · EPSS 1.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • libvirt

    Versions
    • 5.0.0: Affected

    No fix published

  • libvirt Debian:12

    Affected ranges
    • ECOSYSTEM: < 5.0.0-1

    Update to 5.0.0-1

  • libvirt Debian:13

    Affected ranges
    • ECOSYSTEM: < 5.0.0-1

    Update to 5.0.0-1

  • libvirt Debian:14

    Affected ranges
    • ECOSYSTEM: < 5.0.0-1

    Update to 5.0.0-1

  • libvirt Ubuntu:16.04:LTS

    Versions
    • 1.2.16-2ubuntu11
    • 1.2.16-2ubuntu12
    • 1.2.16-2ubuntu13
    • 1.2.16-2ubuntu14
    • 1.2.21-2ubuntu1
    • 1.2.21-2ubuntu3
    • 1.2.21-2ubuntu4
    • 1.2.21-2ubuntu5
    • 1.2.21-2ubuntu7
    • 1.2.21-2ubuntu8
    • 1.2.21-2ubuntu9
    • 1.2.21-2ubuntu10
    • 1.3.1-1ubuntu1
    • 1.3.1-1ubuntu2
    • 1.3.1-1ubuntu3
    • 1.3.1-1ubuntu4
    • 1.3.1-1ubuntu6
    • 1.3.1-1ubuntu9
    • 1.3.1-1ubuntu10
    • 1.3.1-1ubuntu10.1
    • 1.3.1-1ubuntu10.2
    • 1.3.1-1ubuntu10.3
    • 1.3.1-1ubuntu10.5
    • 1.3.1-1ubuntu10.6
    • 1.3.1-1ubuntu10.7
    • 1.3.1-1ubuntu10.8
    • 1.3.1-1ubuntu10.10
    • 1.3.1-1ubuntu10.11
    • 1.3.1-1ubuntu10.12
    • 1.3.1-1ubuntu10.13
    • 1.3.1-1ubuntu10.14
    • 1.3.1-1ubuntu10.15
    • 1.3.1-1ubuntu10.17
    • 1.3.1-1ubuntu10.18
    • 1.3.1-1ubuntu10.19
    • 1.3.1-1ubuntu10.21
    • 1.3.1-1ubuntu10.22
    • 1.3.1-1ubuntu10.23
    • 1.3.1-1ubuntu10.24
    Affected ranges
    • ECOSYSTEM: < 1.3.1-1ubuntu10.25

    Update to 1.3.1-1ubuntu10.25

  • libvirt Ubuntu:18.04:LTS

    Versions
    • 3.6.0-1ubuntu5
    • 3.6.0-1ubuntu6
    • 4.0.0-1ubuntu1
    • 4.0.0-1ubuntu2
    • 4.0.0-1ubuntu3
    • 4.0.0-1ubuntu4
    • 4.0.0-1ubuntu5
    • 4.0.0-1ubuntu6
    • 4.0.0-1ubuntu7
    • 4.0.0-1ubuntu8
    • 4.0.0-1ubuntu8.1
    • 4.0.0-1ubuntu8.2
    • 4.0.0-1ubuntu8.3
    • 4.0.0-1ubuntu8.4
    • 4.0.0-1ubuntu8.5
    • 4.0.0-1ubuntu8.6
    • 4.0.0-1ubuntu8.7
    Affected ranges
    • ECOSYSTEM: < 4.0.0-1ubuntu8.8

    Update to 4.0.0-1ubuntu8.8

Original sources

Check your server →