CVE-2019-3848
CVE-2019-3848
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability was found in moodle before versions 3.6.3, 3.5.5 and 3.4.8. Permissions were not correctly checked before loading event information into the calendar's edit event modal popup, so logged in non-guest users could view unauthorised calendar events. (Note: It was read-only access, users could not edit the events.)
CVSS 4.3 · Medium · EPSS 0.9% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
moodle
- Versions
- 3.6.3: Affected
- 3.5.5: Affected
- 3.4.8: Affected
No fix published
moodle/moodle Packagist
- Versions
- v3.4.0
- v3.4.0-beta
- v3.4.0-rc1
- v3.4.0-rc2
- v3.4.0-rc3
- v3.4.1
- v3.4.2
- v3.4.3
- v3.4.4
- v3.4.5
- v3.4.6
- v3.4.7
- Affected ranges
- ECOSYSTEM: ≥ 3.4, < 3.4.8
Update to 3.4.8
moodle/moodle Packagist
- Versions
- v3.5.0
- v3.5.0-beta
- v3.5.0-rc1
- v3.5.1
- v3.5.2
- v3.5.3
- v3.5.4
- Affected ranges
- ECOSYSTEM: ≥ 3.5, < 3.5.5
Update to 3.5.5
moodle/moodle Packagist
- Versions
- v3.6.0
- v3.6.0-beta
- v3.6.0-rc1
- v3.6.0-rc2
- v3.6.0-rc3
- v3.6.1
- v3.6.2
- Affected ranges
- ECOSYSTEM: ≥ 3.6, < 3.6.3
Update to 3.6.3