CVE-2019-3852
CVE-2019-3852
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability was found in moodle before version 3.6.3. The get_with_capability_join and get_users_by_capability functions were not taking context freezing into account when checking user capabilities
CVSS 4.3 · Medium · EPSS 1.1% · Fix available
- Published
- Updated
Affected products and versions
moodle
- Versions
- 3.6.3: Affected
No fix published
moodle/moodle Packagist
- Versions
- v3.6.0
- v3.6.0-beta
- v3.6.0-rc1
- v3.6.0-rc2
- v3.6.0-rc3
- v3.6.1
- v3.6.2
- Affected ranges
- ECOSYSTEM: ≥ 3.6, < 3.6.3
Update to 3.6.3
moodle Ubuntu:Pro:16.04:LTS
- Versions
- 2.7.9+dfsg-1
- 2.7.10+dfsg-1
- 2.7.11+dfsg-1
- 2.7.11+dfsg-2
- 2.7.12+dfsg-1
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
moodle Ubuntu:Pro:18.04:LTS
- Versions
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published