p PatchFirst

CVE-2019-3871

CVE-2019-3871

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A vulnerability was found in PowerDNS Authoritative Server before 4.0.7 and before 4.1.7. An insufficient validation of data coming from the user when building a HTTP request from a DNS query in the HTTP Connector of the Remote backend, allowing a remote user to cause a denial of service by making the server connect to an invalid endpoint, or possibly information disclosure by making the server connect to an internal endpoint and somehow extracting meaningful information about the response

CVSS 6.5 · Medium · EPSS 12.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • pdns

    Versions
    • 4.1.7: Affected
    • 4.0.7: Affected

    No fix published

  • pdns Debian:12

    Affected ranges
    • ECOSYSTEM: < 4.1.6-2

    Update to 4.1.6-2

  • pdns Debian:13

    Affected ranges
    • ECOSYSTEM: < 4.1.6-2

    Update to 4.1.6-2

  • pdns Debian:14

    Affected ranges
    • ECOSYSTEM: < 4.1.6-2

    Update to 4.1.6-2

  • pdns Ubuntu:Pro:16.04:LTS

    Versions
    • 3.4.5-1build2
    • 3.4.6-2
    • 3.4.6-3
    • 3.4.7-1
    • 3.4.7-2
    • 4.0.0~alpha1-1
    • 4.0.0~alpha2-2
    • 4.0.0~alpha2-3
    • 4.0.0~alpha2-3build1
    • 4.0.0~alpha2-3ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • pdns Ubuntu:Pro:18.04:LTS

    Versions
    • 4.0.4-2
    • 4.0.4-2build1
    • 4.0.5-1
    • 4.1.0-1
    • 4.1.0-2
    • 4.1.0-2build1
    • 4.1.1-1
    • 4.1.1-1ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →