CVE-2019-5051
CVE-2019-5051
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An exploitable heap-based buffer overflow vulnerability exists when loading a PCX file in SDL2_image, version 2.0.4. A missing error handler can lead to a buffer overflow and potential code execution. An attacker can provide a specially crafted image file to trigger this vulnerability.
CVSS 8.8 · High · EPSS 4.0% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
simple directmedia
- Versions
- Simple DirectMedia Layer SDL2_image 2.0.4: Affected
No fix published
libsdl2-image Debian:12
- Affected ranges
- ECOSYSTEM: < 2.0.5+dfsg1-1
Update to 2.0.5+dfsg1-1
libsdl2-image Debian:13
- Affected ranges
- ECOSYSTEM: < 2.0.5+dfsg1-1
Update to 2.0.5+dfsg1-1
libsdl2-image Debian:14
- Affected ranges
- ECOSYSTEM: < 2.0.5+dfsg1-1
Update to 2.0.5+dfsg1-1
sdl-image1.2 Debian:12
- Affected ranges
- ECOSYSTEM: < 1.2.12-11
Update to 1.2.12-11
sdl-image1.2 Debian:13
- Affected ranges
- ECOSYSTEM: < 1.2.12-11
Update to 1.2.12-11
sdl-image1.2 Debian:14
- Affected ranges
- ECOSYSTEM: < 1.2.12-11
Update to 1.2.12-11
libsdl2-image Ubuntu:Pro:14.04:LTS
- Versions
- 2.0.0+dfsg-2
- 2.0.0+dfsg-3
- 2.0.0+dfsg-3build2
- 2.0.0+dfsg-3+deb8u1build0.14.04.1
- Affected ranges
- ECOSYSTEM: < 2.0.0+dfsg-3+deb8u2build0.14.04.1~esm1
Update to 2.0.0+dfsg-3+deb8u2build0.14.04.1~esm1
sdl-image1.2 Ubuntu:Pro:14.04:LTS
- Versions
- 1.2.12-4ubuntu1
- 1.2.12-5
- 1.2.12-5build2
- 1.2.12-5+deb9u1build0.14.04.1
- Affected ranges
- ECOSYSTEM: < 1.2.12-5+deb9u1ubuntu0.14.04.1~esm1
Update to 1.2.12-5+deb9u1ubuntu0.14.04.1~esm1
sdl-image1.2 Ubuntu:16.04:LTS
- Versions
- 1.2.12-5build2
- 1.2.12-5+deb9u1build0.16.04.1
- Affected ranges
- ECOSYSTEM: < 1.2.12-5+deb9u1ubuntu0.16.04.1
Update to 1.2.12-5+deb9u1ubuntu0.16.04.1
libsdl2-image Ubuntu:16.04:LTS
- Versions
- 2.0.0+dfsg-3build2
- 2.0.1+dfsg-1
- 2.0.1+dfsg-2
- 2.0.1+dfsg-2+deb9u1build0.16.04.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
sdl-image1.2 Ubuntu:18.04:LTS
- Versions
- 1.2.12-6
- 1.2.12-7
- 1.2.12-8
- Affected ranges
- ECOSYSTEM: < 1.2.12-8ubuntu0.1
Update to 1.2.12-8ubuntu0.1
libsdl2-image Ubuntu:18.04:LTS
- Versions
- 2.0.1+dfsg-3
- 2.0.1+dfsg-4
- 2.0.2+dfsg1-1
- 2.0.3+dfsg1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://lists.debian.org/debian-lts-announce/2019/07/msg00026.html
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00012.html
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00029.html
- https://usn.ubuntu.com/4238-1/
- https://talosintelligence.com/vulnerability_reports/TALOS-2019-0820
- https://nvd.nist.gov/vuln/detail/CVE-2019-5051