p PatchFirst

CVE-2019-5953

CVE-2019-5953

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Buffer overflow in GNU Wget 1.20.1 and earlier allows remote attackers to cause a denial-of-service (DoS) or may execute an arbitrary code via unspecified vectors.

CVSS 9.8 · Critical · EPSS 5.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gnu wget

    Versions
    • 1.20.1 and earlier: Affected

    No fix published

  • wget Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.20.1-1.1

    Update to 1.20.1-1.1

  • wget Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.20.1-1.1

    Update to 1.20.1-1.1

  • wget Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.20.1-1.1

    Update to 1.20.1-1.1

  • wget Ubuntu:14.04:LTS

    Versions
    • 1.14-2ubuntu1
    • 1.14-5ubuntu1
    • 1.15-1ubuntu1
    • 1.15-1ubuntu1.14.04.1
    • 1.15-1ubuntu1.14.04.2
    • 1.15-1ubuntu1.14.04.3
    • 1.15-1ubuntu1.14.04.4
    Affected ranges
    • ECOSYSTEM: < 1.15-1ubuntu1.14.04.5

    Update to 1.15-1ubuntu1.14.04.5

  • wget Ubuntu:16.04:LTS

    Versions
    • 1.16.1-1ubuntu1
    • 1.17.1-1ubuntu1
    • 1.17.1-1ubuntu1.1
    • 1.17.1-1ubuntu1.2
    • 1.17.1-1ubuntu1.3
    • 1.17.1-1ubuntu1.4
    Affected ranges
    • ECOSYSTEM: < 1.17.1-1ubuntu1.5

    Update to 1.17.1-1ubuntu1.5

  • wget Ubuntu:18.04:LTS

    Versions
    • 1.19.1-3ubuntu1
    • 1.19.1-3ubuntu1.1
    • 1.19.2-1ubuntu1
    • 1.19.3-2ubuntu1
    • 1.19.4-1ubuntu2
    • 1.19.4-1ubuntu2.1
    Affected ranges
    • ECOSYSTEM: < 1.19.4-1ubuntu2.2

    Update to 1.19.4-1ubuntu2.2

Original sources

Check your server →