CVE-2019-6690
CVE-2019-6690
This page contains facts from public vulnerability sources. Check the original advisory before updating.
python-gnupg 0.4.3 allows context-dependent attackers to trick gnupg to decrypt other ciphertext than intended. To perform the attack, the passphrase to gnupg must be controlled by the adversary and the ciphertext should be trusted. Related to a "CWE-20: Improper Input Validation" issue affecting the affect functionality component.
CVSS 7.5 · High · EPSS 8.6% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
python-gnupg Debian:12
- Affected ranges
- ECOSYSTEM: < 0.4.4-1
Update to 0.4.4-1
python-gnupg Debian:13
- Affected ranges
- ECOSYSTEM: < 0.4.4-1
Update to 0.4.4-1
python-gnupg Debian:14
- Affected ranges
- ECOSYSTEM: < 0.4.4-1
Update to 0.4.4-1
python-gnupg PyPI
- Versions
- 0.2.3
- 0.2.4
- 0.2.6
- 0.2.7
- 0.2.8
- 0.2.9
- 0.3.0
- 0.3.1
- 0.3.2
- 0.3.3
- 0.3.4
- 0.3.5
- 0.3.6
- 0.3.7
- 0.3.8
- 0.3.9
- 0.4.0
- 0.4.1
- 0.4.2
- 0.4.3
- Affected ranges
- ECOSYSTEM: < 0.4.4
Update to 0.4.4
python-gnupg Ubuntu:Pro:14.04:LTS
- Versions
- 0.3.5-2
- 0.3.6-1
- Affected ranges
- ECOSYSTEM: < 0.3.6-1ubuntu0.1~esm1
Update to 0.3.6-1ubuntu0.1~esm1
python-gnupg Ubuntu:Pro:16.04:LTS
- Versions
- 0.3.7-2
- 0.3.8-1
- 0.3.8-2
- Affected ranges
- ECOSYSTEM: < 0.3.8-2ubuntu0.1~esm1
Update to 0.3.8-2ubuntu0.1~esm1
python-gnupg Ubuntu:18.04:LTS
- Versions
- 0.3.9-1
- 0.4.1-1ubuntu1
- Affected ranges
- ECOSYSTEM: < 0.4.1-1ubuntu1.18.04.1
Update to 0.4.1-1ubuntu1.18.04.1
python-gnupg Ubuntu:20.04:LTS
- Versions
- 0.4.3-1ubuntu1
- 0.4.5-1
- 0.4.5-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
python-gnupg Ubuntu:22.04:LTS
- Versions
- 0.4.6-1
- 0.4.7-1
- 0.4.8-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- http://www.securityfocus.com/bid/106756
- http://packetstormsecurity.com/files/151341/Python-GnuPG-0.4.3-Improper-Input-Validation.html
- https://pypi.org/project/python-gnupg/#history
- http://lists.opensuse.org/opensuse-security-announce/2019-02/msg00008.html
- http://lists.opensuse.org/opensuse-security-announce/2019-02/msg00058.html
- https://lists.debian.org/debian-lts-announce/2019/02/msg00021.html
- https://seclists.org/bugtraq/2019/Jan/41
- https://blog.hackeriet.no/cve-2019-6690-python-gnupg-vulnerability/
- https://usn.ubuntu.com/3964-1/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/W6KYZMN2PWXY4ENZVJUVTGFBVYEVY7II/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/X4VFRUG56542LTYK4444TPJBGR57MT25/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/3WMV6XNPPL3VB3RQRFFOBCJ3AGWC4K47/
- https://lists.debian.org/debian-lts-announce/2021/12/msg00027.html
- https://nvd.nist.gov/vuln/detail/CVE-2019-6690