CVE-2019-7304
CVE-2019-7304 · Local privilege escalation via snapd socket
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Canonical snapd before version 2.37.1 incorrectly performed socket owner validation, allowing an attacker to run arbitrary commands as root. This issue affects: Canonical snapd versions prior to 2.37.1.
CVSS 8.8 · High · EPSS 60.8% · Public exploit · Fix available
- Published
- Updated
Stack: system
Affected products and versions
snapd
- Versions
- ≥ unspecified, < 2.37.1: Affected (custom)
Update to 2.37.1
snapd Debian:12
- Affected ranges
- ECOSYSTEM: < 2.37.1-1
Update to 2.37.1-1
snapd Debian:13
- Affected ranges
- ECOSYSTEM: < 2.37.1-1
Update to 2.37.1-1
snapd Debian:14
- Affected ranges
- ECOSYSTEM: < 2.37.1-1
Update to 2.37.1-1
snapd Ubuntu:14.04:LTS
- Versions
- 2.21~14.04.2
- 2.22.2~14.04
- 2.22.3~14.04
- 2.22.6~14.04
- 2.23.1~14.04
- 2.24.1~14.04
- 2.25~14.04
- 2.26.10~14.04
- 2.27.5~14.04
- 2.28.5~14.04
- 2.29.4.2~14.04
- 2.32.3.2~14.04
- 2.32.9~14.04
- 2.33.1~14.04
- 2.34.2~14.04
- Affected ranges
- ECOSYSTEM: < 2.34.2~14.04.1
Update to 2.34.2~14.04.1
snapd Ubuntu:16.04:LTS
- Versions
- 1.9
- 1.9.1.1
- 1.9.2
- 2.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.5
- 2.0.8
- 2.0.9
- 2.0.10
- 2.11+0.16.04
- 2.12+0.16.04
- 2.13
- 2.14.2~16.04
- 2.15.2ubuntu1
- 2.16ubuntu3
- 2.17.1ubuntu1
- 2.20.1ubuntu1
- 2.21
- 2.22.2
- 2.22.3
- 2.22.6
- 2.23.1
- 2.24.1
- 2.25
- 2.26.10
- 2.27.5
- 2.28.5
- 2.29.4.2
- 2.32.3.2
- 2.32.9
- 2.33.1ubuntu2
- 2.34.2
- Affected ranges
- ECOSYSTEM: < 2.34.2ubuntu0.1
Update to 2.34.2ubuntu0.1
snapd Ubuntu:18.04:LTS
- Versions
- 2.28.5+17.10
- 2.29.4.1+18.04
- 2.29.4.2+18.04
- 2.31.1+18.04
- 2.32+18.04~pre5
- 2.32+18.04~pre6
- 2.32+18.04
- 2.32.3.2+18.04
- 2.32.5+18.04
- 2.32.8+18.04
- 2.32.9+18.04
- 2.33.1+18.04ubuntu2
- 2.34.2+18.04
- Affected ranges
- ECOSYSTEM: < 2.34.2+18.04.1
Update to 2.34.2+18.04.1