CVE-2019-7575
CVE-2019-7575
This page contains facts from public vulnerability sources. Check the original advisory before updating.
SDL (Simple DirectMedia Layer) through 1.2.15 and 2.x through 2.0.9 has a heap-based buffer overflow in MS_ADPCM_decode in audio/SDL_wave.c.
CVSS 8.8 · High · EPSS 2.9% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
libsdl1.2 Debian:12
- Affected ranges
- ECOSYSTEM: < 1.2.15+dfsg2-5
Update to 1.2.15+dfsg2-5
libsdl2 Debian:12
- Affected ranges
- ECOSYSTEM: < 2.0.10+dfsg1-1
Update to 2.0.10+dfsg1-1
libsdl2 Debian:13
- Affected ranges
- ECOSYSTEM: < 2.0.10+dfsg1-1
Update to 2.0.10+dfsg1-1
libsdl2 Debian:14
- Affected ranges
- ECOSYSTEM: < 2.0.10+dfsg1-1
Update to 2.0.10+dfsg1-1
libsdl1.2 Ubuntu:Pro:14.04:LTS
- Versions
- 1.2.15-5ubuntu2
- 1.2.15-5ubuntu3
- 1.2.15-8ubuntu1
- 1.2.15-8ubuntu1.1
- Affected ranges
- ECOSYSTEM: < 1.2.15-8ubuntu1.1+esm1
Update to 1.2.15-8ubuntu1.1+esm1
libsdl2 Ubuntu:Pro:14.04:LTS
- Versions
- 2.0.0+dfsg1-2
- 2.0.0+dfsg1-3
- 2.0.1+dfsg1-1
- 2.0.1+dfsg1-1ubuntu1
- 2.0.2+dfsg1-3
- 2.0.2+dfsg1-3ubuntu1
- 2.0.2+dfsg1-3ubuntu1.1
- 2.0.2+dfsg1-3ubuntu1.2
- 2.0.2+dfsg1-3ubuntu1.3
- Affected ranges
- ECOSYSTEM: < 2.0.2+dfsg1-3ubuntu1.3+esm1
Update to 2.0.2+dfsg1-3ubuntu1.3+esm1
libsdl1.2 Ubuntu:16.04:LTS
- Versions
- 1.2.15-11ubuntu1
- 1.2.15-12ubuntu1
- 1.2.15+dfsg1-3
- Affected ranges
- ECOSYSTEM: < 1.2.15+dfsg1-3ubuntu0.1
Update to 1.2.15+dfsg1-3ubuntu0.1
libsdl2 Ubuntu:16.04:LTS
- Versions
- 2.0.2+dfsg1-6ubuntu2
- 2.0.4+dfsg1-2
- 2.0.4+dfsg1-2ubuntu1
- 2.0.4+dfsg1-2ubuntu2
- 2.0.4+dfsg1-2ubuntu2.16.04.1
- 2.0.4+dfsg1-2ubuntu2.16.04.2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libsdl1.2 Ubuntu:18.04:LTS
- Versions
- 1.2.15+dfsg2-0.1
- Affected ranges
- ECOSYSTEM: < 1.2.15+dfsg2-0.1ubuntu0.1
Update to 1.2.15+dfsg2-0.1ubuntu0.1
libsdl2 Ubuntu:Pro:18.04:LTS
- Versions
- 2.0.6+dfsg1-3ubuntu1
- 2.0.6+dfsg1-4ubuntu1
- 2.0.7+dfsg1-3ubuntu1
- 2.0.8+dfsg1-1ubuntu1
- 2.0.8+dfsg1-1ubuntu1.18.04.1
- 2.0.8+dfsg1-1ubuntu1.18.04.3
- 2.0.8+dfsg1-1ubuntu1.18.04.4
- 2.0.8+dfsg1-1ubuntu1.18.04.4+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://lists.debian.org/debian-lts-announce/2019/03/msg00016.html
- https://lists.debian.org/debian-lts-announce/2019/03/msg00015.html
- https://bugzilla.libsdl.org/show_bug.cgi?id=4493
- https://discourse.libsdl.org/t/vulnerabilities-found-in-libsdl-1-2-15/25720
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00063.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00073.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00088.html
- https://security.gentoo.org/glsa/201909-07
- https://usn.ubuntu.com/4156-1/
- https://usn.ubuntu.com/4156-2/
- https://lists.debian.org/debian-lts-announce/2019/10/msg00021.html
- https://lists.debian.org/debian-lts-announce/2019/10/msg00020.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/7ZO47LLKKRXKMUGSRCFNHSTHG5OEBYCG/
- https://lists.debian.org/debian-lts-announce/2021/01/msg00024.html
- https://lists.debian.org/debian-lts-announce/2021/10/msg00032.html
- https://lists.debian.org/debian-lts-announce/2023/02/msg00008.html
- https://security.gentoo.org/glsa/202305-17
- https://nvd.nist.gov/vuln/detail/CVE-2019-7575