CVE-2019-8114
CVE-2019-8114
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A remote code execution vulnerability exists in Magento 1 prior to 1.9.4.3 and 1.14.4.3, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with admin privileges to import features can execute arbitrary code via crafted configuration archive file upload.
CVSS 7.2 · High · EPSS 1.9% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
magento 1 & 2
- Versions
- Magento Open Source prior to 1.9.4.3: Affected
- and Magento Commerce prior to 1.14.4.3: Affected
- Magento 2.2 prior to 2.2.10: Affected
- Magento 2.3 prior to 2.3.3 or 2.3.2-p1: Affected
No fix published
magento/community-edition Packagist
- Versions
- 0.1.0-alpha100
- 0.1.0-alpha101
- 0.1.0-alpha102
- 0.1.0-alpha103
- 0.1.0-alpha104
- 0.1.0-alpha105
- 0.1.0-alpha106
- 0.1.0-alpha107
- 0.1.0-alpha108
- 0.1.0-alpha89
- 0.1.0-alpha90
- 0.1.0-alpha91
- 0.1.0-alpha92
- 0.1.0-alpha93
- 0.1.0-alpha94
- 0.1.0-alpha95
- 0.1.0-alpha96
- 0.1.0-alpha97
- 0.1.0-alpha98
- 0.1.0-alpha99
- 0.42.0-beta1
- 0.42.0-beta10
- 0.42.0-beta11
- 0.42.0-beta2
- 0.42.0-beta3
- 0.42.0-beta4
- 0.42.0-beta5
- 0.42.0-beta6
- 0.42.0-beta7
- 0.42.0-beta8
- 0.42.0-beta9
- 0.74.0-beta1
- 0.74.0-beta10
- 0.74.0-beta11
- 0.74.0-beta12
- 0.74.0-beta13
- 0.74.0-beta14
- 0.74.0-beta15
- 0.74.0-beta16
- 0.74.0-beta2
- 0.74.0-beta3
- 0.74.0-beta4
- 0.74.0-beta5
- 0.74.0-beta6
- 0.74.0-beta7
- 0.74.0-beta8
- 0.74.0-beta9
- 1.0.0-beta
- 1.0.0-beta2
- 1.0.0-beta3
- 1.0.0-beta4
- 1.0.0-beta5
- 1.0.0-beta6
- Affected ranges
- ECOSYSTEM: < 1.9.4.3
Update to 1.9.4.3
magento/community-edition Packagist
- Versions
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.2.4
- 2.2.5
- 2.2.6
- 2.2.7
- 2.2.8
- 2.2.9
- Affected ranges
- ECOSYSTEM: ≥ 2.2.0, < 2.2.10
Update to 2.2.10
magento/community-edition Packagist
- Versions
- 2.3.0
- 2.3.1
- 2.3.2
- Affected ranges
- ECOSYSTEM: ≥ 2.3.0, < 2.3.2-p2
Update to 2.3.2-p2
magento/project-community-edition Packagist
- Versions
- 0.1.0-alpha100
- 0.1.0-alpha101
- 0.1.0-alpha102
- 0.1.0-alpha103
- 0.1.0-alpha104
- 0.1.0-alpha105
- 0.1.0-alpha106
- 0.1.0-alpha107
- 0.1.0-alpha108
- 0.1.0-alpha89
- 0.1.0-alpha90
- 0.1.0-alpha91
- 0.1.0-alpha92
- 0.1.0-alpha93
- 0.1.0-alpha94
- 0.1.0-alpha95
- 0.1.0-alpha96
- 0.1.0-alpha97
- 0.1.0-alpha98
- 0.1.0-alpha99
- 0.42.0-beta1
- 0.42.0-beta10
- 0.42.0-beta11
- 0.42.0-beta2
- 0.42.0-beta3
- 0.42.0-beta4
- 0.42.0-beta5
- 0.42.0-beta6
- 0.42.0-beta7
- 0.42.0-beta8
- 0.42.0-beta9
- 0.74.0-beta1
- 0.74.0-beta10
- 0.74.0-beta11
- 0.74.0-beta12
- 0.74.0-beta13
- 0.74.0-beta14
- 0.74.0-beta15
- 0.74.0-beta16
- 0.74.0-beta2
- 0.74.0-beta3
- 0.74.0-beta4
- 0.74.0-beta5
- 0.74.0-beta6
- 0.74.0-beta7
- 0.74.0-beta8
- 0.74.0-beta9
- 1.0.0-beta
- Affected ranges
- ECOSYSTEM: < 1.9.4.3
Update to 1.9.4.3