p PatchFirst

CVE-2019-8120

CVE-2019-8120

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A stored cross-site scripting (XSS) vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. An authenticated user can inject arbitrary Javascript code by manipulating section of a POST request related to customer's email address.

CVSS 5.4 · Medium · EPSS 0.6% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • magento 2

    Versions
    • Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p2: Affected

    No fix published

  • magento/community-edition Packagist

    Versions
    • 2.1.0
    • 2.1.1
    • 2.1.10
    • 2.1.11
    • 2.1.12
    • 2.1.13
    • 2.1.14
    • 2.1.15
    • 2.1.16
    • 2.1.17
    • 2.1.18
    • 2.1.2
    • 2.1.3
    • 2.1.4
    • 2.1.5
    • 2.1.6
    • 2.1.7
    • 2.1.8
    • 2.1.9
    Affected ranges
    • ECOSYSTEM: ≥ 2.1.0, < 2.1.19

    Update to 2.1.19

  • magento/community-edition Packagist

    Versions
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.2.3
    • 2.2.4
    • 2.2.5
    • 2.2.6
    • 2.2.7
    • 2.2.8
    • 2.2.9
    Affected ranges
    • ECOSYSTEM: ≥ 2.2.0, < 2.2.10

    Update to 2.2.10

  • magento/community-edition Packagist

    Versions
    • 2.3.0
    • 2.3.1
    • 2.3.2
    • 2.3.2-p2
    Affected ranges
    • ECOSYSTEM: ≥ 2.3.0, < 2.3.3

    Update to 2.3.3

Original sources

Check your server →