CVE-2019-8308
CVE-2019-8308
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Flatpak before 1.0.7, and 1.1.x and 1.2.x before 1.2.3, exposes /proc in the apply_extra script sandbox, which allows attackers to modify a host-side executable file.
CVSS 8.2 · High · EPSS 0.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
flatpak Debian:12
- Affected ranges
- ECOSYSTEM: < 1.2.3-1
Update to 1.2.3-1
flatpak Debian:13
- Affected ranges
- ECOSYSTEM: < 1.2.3-1
Update to 1.2.3-1
flatpak Debian:14
- Affected ranges
- ECOSYSTEM: < 1.2.3-1
Update to 1.2.3-1
flatpak Ubuntu:18.04:LTS
- Versions
- 0.8.7-5
- 0.10.0-1
- 0.10.0-2
- 0.10.1-1
- 0.10.2-1
- 0.10.2.1-1
- 0.10.2.1-2
- 0.10.3-1
- 0.11.1-0ubuntu1
- 0.11.3-2
- 0.11.3-3
- 0.11.7-0ubuntu0.1
- 1.0.1-0ubuntu0.1
- 1.0.6-0ubuntu0.1
- Affected ranges
- ECOSYSTEM: < 1.0.7-0ubuntu0.18.04.1
Update to 1.0.7-0ubuntu0.18.04.1
Original sources
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=922059
- https://github.com/flatpak/flatpak/releases/tag/1.2.3
- https://github.com/flatpak/flatpak/releases/tag/1.0.7
- https://access.redhat.com/errata/RHSA-2019:0375
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00088.html
- https://nvd.nist.gov/vuln/detail/CVE-2019-8308