p PatchFirst

CVE-2019-8942

CVE-2019-8942

This page contains facts from public vulnerability sources. Check the original advisory before updating.

WordPress before 4.9.9 and 5.x before 5.0.1 allows remote code execution because an _wp_attached_file Post Meta entry can be changed to an arbitrary string, such as one ending with a .jpg?file.php substring. An attacker with author privileges can execute arbitrary code by uploading a crafted image containing PHP code in the Exif metadata. Exploitation can leverage CVE-2019-8943.

CVSS 8.8 · High · EPSS 82.7% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • wordpress Debian:12

    Affected ranges
    • ECOSYSTEM: < 5.0.1+dfsg1-1

    Update to 5.0.1+dfsg1-1

  • wordpress Debian:13

    Affected ranges
    • ECOSYSTEM: < 5.0.1+dfsg1-1

    Update to 5.0.1+dfsg1-1

  • wordpress Debian:14

    Affected ranges
    • ECOSYSTEM: < 5.0.1+dfsg1-1

    Update to 5.0.1+dfsg1-1

  • wordpress Ubuntu:16.04:LTS

    Versions
    • 4.3+dfsg-1
    • 4.3.1+dfsg-1
    • 4.4+dfsg-1
    • 4.4.1+dfsg-1
    • 4.4.2+dfsg-1
    • 4.4.2+dfsg-1ubuntu1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • wordpress Ubuntu:18.04:LTS

    Versions
    • 4.8.2+dfsg-2
    • 4.8.3+dfsg-1
    • 4.9.1+dfsg-1
    • 4.9.2+dfsg-1
    • 4.9.4+dfsg-1
    • 4.9.5+dfsg1-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →