p PatchFirst

CVE-2019-9003

CVE-2019-9003

This page contains facts from public vulnerability sources. Check the original advisory before updating.

In the Linux kernel before 4.20.5, attackers can trigger a drivers/char/ipmi/ipmi_msghandler.c use-after-free and OOPS by arranging for certain simultaneous execution of the code, as demonstrated by a "service ipmievd restart" loop.

CVSS 7.5 · High · EPSS 4.8% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • linux Debian:12

    Affected ranges
    • ECOSYSTEM: < 4.19.20-1

    Update to 4.19.20-1

  • linux Debian:13

    Affected ranges
    • ECOSYSTEM: < 4.19.20-1

    Update to 4.19.20-1

  • linux Debian:14

    Affected ranges
    • ECOSYSTEM: < 4.19.20-1

    Update to 4.19.20-1

  • linux-azure Ubuntu:18.04:LTS

    Versions
    • 4.15.0-1002.2
    • 4.15.0-1003.3
    • 4.15.0-1004.4
    • 4.15.0-1008.8
    • 4.15.0-1009.9
    • 4.15.0-1012.12
    • 4.15.0-1013.13
    • 4.15.0-1014.14
    • 4.15.0-1018.18
    • 4.15.0-1019.19
    • 4.15.0-1021.21
    • 4.15.0-1022.23
    • 4.15.0-1023.24
    • 4.15.0-1025.26
    • 4.15.0-1028.29
    • 4.15.0-1030.31
    • 4.15.0-1031.32
    • 4.15.0-1032.33
    • 4.15.0-1035.36
    • 4.15.0-1036.38
    • 4.15.0-1037.39
    • 4.18.0-1011.11~18.04.1
    • 4.18.0-1013.13~18.04.1
    Affected ranges
    • ECOSYSTEM: < 4.18.0-1014.14~18.04.1

    Update to 4.18.0-1014.14~18.04.1

  • linux-gcp-edge Ubuntu:18.04:LTS

    Versions
    • 4.18.0-1004.5~18.04.1
    • 4.18.0-1005.6~18.04.1
    • 4.18.0-1006.7~18.04.1
    • 4.18.0-1007.8~18.04.1
    Affected ranges
    • ECOSYSTEM: < 4.18.0-1008.9~18.04.1

    Update to 4.18.0-1008.9~18.04.1

  • linux-hwe Ubuntu:18.04:LTS

    Versions
    • 4.18.0-13.14~18.04.1
    • 4.18.0-14.15~18.04.1
    • 4.18.0-15.16~18.04.1
    • 4.18.0-16.17~18.04.1
    Affected ranges
    • ECOSYSTEM: < 4.18.0-17.18~18.04.1

    Update to 4.18.0-17.18~18.04.1

Original sources

Check your server →