CVE-2019-9215
CVE-2019-9215
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In Live555 before 2019.02.27, malformed headers lead to invalid memory access in the parseAuthorizationHeader function.
CVSS 9.8 · Critical · EPSS 2.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
liblivemedia Debian:14
- Versions
- 2004.11.11a-1
- 2005.04.01-1
- 2005.06.16-1
- 2005.07.21-1
- 2005.10.05-1
- 2006.03.17-1
- 2006.03.17-2
- 2007.02.20-1
- 2007.02.20-2
- 2008.07.25-1
- 2008.07.25-2
- 2009.11.27-1
- 2010.02.10-1
- 2010.04.09-1
- 2010.11.17-1
- 2011.03.14-1
- 2011.05.25-1
- 2011.06.16-1
- 2011.07.08-1
- 2011.07.21-1
- 2011.08.22-1
- 2011.09.02-1
- 2011.12.23-1
- 2012.02.04-1
- 2012.02.29-1
- 2012.02.29-2
- 2012.04.04-1
- 2012.04.21-1
- 2012.05.03-1
- 2012.05.03-1~bpo60+1
- 2012.05.17-1
- 2012.05.17-1+wheezy1
- 2012.05.17-1~bpo60+1
- 2012.08.31-1
- 2012.10.24-1
- 2012.11.16-1
- 2012.11.30-1
- 2013.01.05-1
- 2013.01.05-2
- 2013.01.05-3
- 2013.01.15-1
- 2013.04.30-1
- 2013.10.25-1
- 2014.01.13-1
- 2015.12.22-1
- 2016.01.12-1
- 2016.01.16-1
- 2016.01.20-1
- 2016.01.29-1
- 2016.01.29-2
- 2016.02.09-1
- 2016.03.16-1
- 2016.04.01-1
- 2016.04.21-1
- 2016.06.26-1
- 2016.07.19-1
- 2016.08.07-1
- 2016.08.27-1
- 2016.09.22-1
- 2016.11.06-1
- 2016.11.17-1
- 2016.11.28-1
- 2017.01.26-1
- 2017.04.10-1
- 2017.04.26-1
- 2017.06.04-1
- 2017.06.04-2
- 2017.07.18-1
- 2017.09.12-1
- 2017.10.28-1
- 2017.10.28-2
- 2018.01.24-1
- 2018.01.29-1
- 2018.02.18-1
- 2018.02.28-1
- 2018.04.25-1
- 2018.04.25-2
- 2018.07.07-1
- 2018.08.05-1
- 2018.08.27-1
- 2018.08.27-2
- 2018.08.28a-1
- 2018.09.06-1
- 2018.09.10-1
- 2018.09.18-1
- 2018.10.17-1
- 2018.11.26-1
- Affected ranges
- ECOSYSTEM: < 2018.11.26-1.1
Update to 2018.11.26-1.1
liblivemedia Ubuntu:Pro:16.04:LTS
- Versions
- 2014.01.13-1
- 2016.01.29-2
- 2016.02.09-1
- Affected ranges
- ECOSYSTEM: < 2016.02.09-1ubuntu0.1~esm1
Update to 2016.02.09-1ubuntu0.1~esm1
liblivemedia Ubuntu:Pro:18.04:LTS
- Versions
- 2017.07.18-1
- 2017.09.12-1ubuntu1
- 2017.10.28-2
- 2018.01.29-1
- 2018.02.18-1
- Affected ranges
- ECOSYSTEM: < 2018.02.18-1ubuntu0.1~esm1
Update to 2018.02.18-1ubuntu0.1~esm1
Original sources
- http://www.live555.com/liveMedia/public/changelog.txt
- https://seclists.org/bugtraq/2019/Mar/22
- https://www.debian.org/security/2019/dsa-4408
- https://lists.debian.org/debian-lts-announce/2019/03/msg00022.html
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00044.html
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00024.html
- https://security.gentoo.org/glsa/202005-06
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00009.html
- https://nvd.nist.gov/vuln/detail/CVE-2019-9215