p PatchFirst

CVE-2019-9517

CVE-2019-9517 · Some HTTP/2 implementations are vulnerable to unconstrained interal data buffering, potentially leading to a denial of service

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

Some HTTP/2 implementations are vulnerable to unconstrained interal data buffering, potentially leading to a denial of service. The attacker opens the HTTP/2 window so the peer can send without constraint; however, they leave the TCP window closed so the peer cannot actually write (many of) the bytes on the wire. The attacker then sends a stream of requests for a large response object. Depending on how the servers queue the responses, this can consume excess memory, CPU, or both.

CVSS 7.5 · High · EPSS 27.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • apache2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.4.41-1

    Update to 2.4.41-1

  • apache2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.4.41-1

    Update to 2.4.41-1

  • apache2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.4.41-1

    Update to 2.4.41-1

  • apache2 Ubuntu:18.04:LTS

    Versions
    • 2.4.27-2ubuntu3
    • 2.4.29-1ubuntu1
    • 2.4.29-1ubuntu2
    • 2.4.29-1ubuntu3
    • 2.4.29-1ubuntu4
    • 2.4.29-1ubuntu4.1
    • 2.4.29-1ubuntu4.2
    • 2.4.29-1ubuntu4.3
    • 2.4.29-1ubuntu4.4
    • 2.4.29-1ubuntu4.5
    • 2.4.29-1ubuntu4.6
    • 2.4.29-1ubuntu4.7
    • 2.4.29-1ubuntu4.8
    Affected ranges
    • ECOSYSTEM: < 2.4.29-1ubuntu4.10

    Update to 2.4.29-1ubuntu4.10

Original sources

Check your server →