CVE-2019-9641
CVE-2019-9641
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An issue was discovered in the EXIF component in PHP before 7.1.27, 7.2.x before 7.2.16, and 7.3.x before 7.3.3. There is an uninitialized read in exif_process_IFD_in_TIFF.
CVSS 9.8 · Critical · EPSS 9.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
php5 Ubuntu:14.04:LTS
- Versions
- 5.5.3+dfsg-1ubuntu2
- 5.5.3+dfsg-1ubuntu3
- 5.5.6+dfsg-1ubuntu1
- 5.5.6+dfsg-1ubuntu2
- 5.5.8+dfsg-2ubuntu1
- 5.5.9+dfsg-1ubuntu1
- 5.5.9+dfsg-1ubuntu2
- 5.5.9+dfsg-1ubuntu3
- 5.5.9+dfsg-1ubuntu4
- 5.5.9+dfsg-1ubuntu4.1
- 5.5.9+dfsg-1ubuntu4.2
- 5.5.9+dfsg-1ubuntu4.3
- 5.5.9+dfsg-1ubuntu4.4
- 5.5.9+dfsg-1ubuntu4.5
- 5.5.9+dfsg-1ubuntu4.6
- 5.5.9+dfsg-1ubuntu4.7
- 5.5.9+dfsg-1ubuntu4.9
- 5.5.9+dfsg-1ubuntu4.11
- 5.5.9+dfsg-1ubuntu4.12
- 5.5.9+dfsg-1ubuntu4.13
- 5.5.9+dfsg-1ubuntu4.14
- 5.5.9+dfsg-1ubuntu4.16
- 5.5.9+dfsg-1ubuntu4.17
- 5.5.9+dfsg-1ubuntu4.19
- 5.5.9+dfsg-1ubuntu4.20
- 5.5.9+dfsg-1ubuntu4.21
- 5.5.9+dfsg-1ubuntu4.22
- 5.5.9+dfsg-1ubuntu4.23
- 5.5.9+dfsg-1ubuntu4.24
- 5.5.9+dfsg-1ubuntu4.25
- 5.5.9+dfsg-1ubuntu4.26
- 5.5.9+dfsg-1ubuntu4.27
- Affected ranges
- ECOSYSTEM: < 5.5.9+dfsg-1ubuntu4.29
Update to 5.5.9+dfsg-1ubuntu4.29
php7.0 Ubuntu:16.04:LTS
- Versions
- 7.0.1-5
- 7.0.1-6
- 7.0.2-1
- 7.0.2-3
- 7.0.2-4
- 7.0.2-5
- 7.0.3-2
- 7.0.3-3
- 7.0.3-9ubuntu1
- 7.0.4-5ubuntu1
- 7.0.4-5ubuntu2
- 7.0.4-7ubuntu1
- 7.0.4-7ubuntu2
- 7.0.4-7ubuntu2.1
- 7.0.8-0ubuntu0.16.04.1
- 7.0.8-0ubuntu0.16.04.2
- 7.0.8-0ubuntu0.16.04.3
- 7.0.13-0ubuntu0.16.04.1
- 7.0.15-0ubuntu0.16.04.1
- 7.0.15-0ubuntu0.16.04.2
- 7.0.15-0ubuntu0.16.04.4
- 7.0.18-0ubuntu0.16.04.1
- 7.0.22-0ubuntu0.16.04.1
- 7.0.25-0ubuntu0.16.04.1
- 7.0.28-0ubuntu0.16.04.1
- 7.0.30-0ubuntu0.16.04.1
- 7.0.32-0ubuntu0.16.04.1
- 7.0.33-0ubuntu0.16.04.1
- 7.0.33-0ubuntu0.16.04.2
- Affected ranges
- ECOSYSTEM: < 7.0.33-0ubuntu0.16.04.3
Update to 7.0.33-0ubuntu0.16.04.3
php7.2 Ubuntu:18.04:LTS
- Versions
- 7.2.1-1ubuntu2
- 7.2.2-1ubuntu1
- 7.2.2-1ubuntu2
- 7.2.3-1ubuntu1
- 7.2.5-0ubuntu0.18.04.1
- 7.2.7-0ubuntu0.18.04.1
- 7.2.7-0ubuntu0.18.04.2
- 7.2.10-0ubuntu0.18.04.1
- 7.2.15-0ubuntu0.18.04.1
- Affected ranges
- ECOSYSTEM: < 7.2.15-0ubuntu0.18.04.2
Update to 7.2.15-0ubuntu0.18.04.2
Original sources
- https://www.debian.org/security/2019/dsa-4403
- https://bugs.php.net/bug.php?id=77509
- https://usn.ubuntu.com/3922-1/
- https://lists.debian.org/debian-lts-announce/2019/03/msg00043.html
- https://usn.ubuntu.com/3922-2/
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00083.html
- https://usn.ubuntu.com/3922-3/
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00104.html
- https://security.netapp.com/advisory/ntap-20190502-0007/
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00041.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00044.html
- https://nvd.nist.gov/vuln/detail/CVE-2019-9641