p PatchFirst

CVE-2019-9644

CVE-2019-9644

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An XSSI (cross-site inclusion) vulnerability in Jupyter Notebook before 5.7.6 allows inclusion of resources on malicious pages when visited by users who are authenticated with a Jupyter server. Access to the content of resources has been demonstrated with Internet Explorer through capturing of error messages, though not reproduced with other browsers. This occurs because Internet Explorer's error messages can include the content of any invalid JavaScript that was encountered.

CVSS 5.4 · Medium · EPSS 1.5% · Fix available

Published
Updated

Stack: system · python

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • jupyter-notebook Debian:12

    Affected ranges
    • ECOSYSTEM: < 5.7.8-1

    Update to 5.7.8-1

  • jupyter-notebook Debian:13

    Affected ranges
    • ECOSYSTEM: < 5.7.8-1

    Update to 5.7.8-1

  • jupyter-notebook Debian:14

    Affected ranges
    • ECOSYSTEM: < 5.7.8-1

    Update to 5.7.8-1

  • jupyter-notebook PyPI

    Versions
    • 4.0.0.dev
    Affected ranges
    • ECOSYSTEM: < 5.7.6

    Update to 5.7.6

  • notebook PyPI

    Versions
    • 0.0.0
    • 4.0.0
    • 4.0.1
    • 4.0.2
    • 4.0.4
    • 4.0.5
    • 4.0.6
    • 4.1.0
    • 4.2.0
    • 4.2.0b1
    • 4.2.1
    • 4.2.2
    • 4.2.3
    • 4.3.0
    • 4.3.1
    • 4.3.2
    • 4.4.0
    • 4.4.1
    • 5.0.0
    • 5.0.0b1
    • 5.0.0b2
    • 5.0.0rc1
    • 5.0.0rc2
    • 5.1.0
    • 5.1.0rc1
    • 5.1.0rc2
    • 5.1.0rc3
    • 5.2.0
    • 5.2.0rc1
    • 5.2.1
    • 5.2.1rc1
    • 5.2.2
    • 5.3.0
    • 5.3.0rc1
    • 5.3.1
    • 5.4.0
    • 5.4.1
    • 5.5.0
    • 5.5.0rc1
    • 5.6.0
    • 5.6.0rc1
    • 5.7.0
    • 5.7.1
    • 5.7.2
    • 5.7.3
    • 5.7.4
    • 5.7.5
    Affected ranges
    • ECOSYSTEM: < 5.7.6

    Update to 5.7.6

  • jupyter-notebook Ubuntu:18.04:LTS

    Versions
    • 4.2.3-4
    • 5.1.0-2
    • 5.2.1-2
    • 5.2.2-1
    Affected ranges
    • ECOSYSTEM: < 5.2.2-1ubuntu0.1

    Update to 5.2.2-1ubuntu0.1

Original sources

Check your server →