CVE-2019-9787
CVE-2019-9787
This page contains facts from public vulnerability sources. Check the original advisory before updating.
WordPress before 5.1.1 does not properly filter comment content, leading to Remote Code Execution by unauthenticated users in a default configuration. This occurs because CSRF protection is mishandled, and because Search Engine Optimization of A elements is performed incorrectly, leading to XSS. The XSS results in administrative access, which allows arbitrary changes to .php files. This is related to wp-admin/includes/ajax-actions.php and wp-includes/comment.php.
CVSS 8.8 · High · EPSS 38.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
wordpress Debian:12
- Affected ranges
- ECOSYSTEM: < 5.1.1+dfsg1-1
Update to 5.1.1+dfsg1-1
wordpress Debian:13
- Affected ranges
- ECOSYSTEM: < 5.1.1+dfsg1-1
Update to 5.1.1+dfsg1-1
wordpress Debian:14
- Affected ranges
- ECOSYSTEM: < 5.1.1+dfsg1-1
Update to 5.1.1+dfsg1-1
wordpress Ubuntu:16.04:LTS
- Versions
- 4.3+dfsg-1
- 4.3.1+dfsg-1
- 4.4+dfsg-1
- 4.4.1+dfsg-1
- 4.4.2+dfsg-1
- 4.4.2+dfsg-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:18.04:LTS
- Versions
- 4.8.2+dfsg-2
- 4.8.3+dfsg-1
- 4.9.1+dfsg-1
- 4.9.2+dfsg-1
- 4.9.4+dfsg-1
- 4.9.5+dfsg1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://blog.ripstech.com/2019/wordpress-csrf-to-rce/
- https://wordpress.org/news/2019/03/wordpress-5-1-1-security-and-maintenance-release/
- https://github.com/WordPress/WordPress/commit/0292de60ec78c5a44956765189403654fe4d080b
- https://wpvulndb.com/vulnerabilities/9230
- http://www.securityfocus.com/bid/107411
- https://wordpress.org/support/wordpress-version/version-5-1-1/
- https://lists.debian.org/debian-lts-announce/2019/03/msg00044.html
- https://www.debian.org/security/2020/dsa-4677
- https://nvd.nist.gov/vuln/detail/CVE-2019-9787