CVE-2020-10713
CVE-2020-10713
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A flaw was found in grub2, prior to version 2.06. An attacker may use the GRUB 2 flaw to hijack and tamper the GRUB verification process. This flaw also allows the bypass of Secure Boot protections. In order to load an untrusted or modified kernel, an attacker would first need to establish access to the system such as gaining physical access, obtain the ability to alter a pxe-boot network, or have remote access to a networked system with root access. With this access, an attacker could then craft a string to cause a buffer overflow by injecting a malicious payload that leads to arbitrary code execution within GRUB. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
CVSS 8.2 · High · EPSS 1.7% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
grub
- Versions
- All grub2 versions before 2.06: Affected
No fix published
grub2 Debian:12
- Affected ranges
- ECOSYSTEM: < 2.04-9
Update to 2.04-9
grub2 Debian:13
- Affected ranges
- ECOSYSTEM: < 2.04-9
Update to 2.04-9
grub2 Debian:14
- Affected ranges
- ECOSYSTEM: < 2.04-9
Update to 2.04-9
grub2 Ubuntu:Pro:14.04:LTS
- Versions
- 2.00-19ubuntu2
- 2.00-19ubuntu3
- 2.00-19ubuntu4
- 2.00-20
- 2.00-21
- 2.00-22
- 2.02~beta2-5
- 2.02~beta2-6
- 2.02~beta2-7
- 2.02~beta2-8
- 2.02~beta2-9
- 2.02~beta2-9ubuntu1
- 2.02~beta2-9ubuntu1.1
- 2.02~beta2-9ubuntu1.2
- 2.02~beta2-9ubuntu1.3
- 2.02~beta2-9ubuntu1.4
- 2.02~beta2-9ubuntu1.5
- 2.02~beta2-9ubuntu1.6
- 2.02~beta2-9ubuntu1.7
- 2.02~beta2-9ubuntu1.8
- 2.02~beta2-9ubuntu1.11
- 2.02~beta2-9ubuntu1.12
- 2.02~beta2-9ubuntu1.14
- 2.02~beta2-9ubuntu1.15
- 2.02~beta2-9ubuntu1.16
- 2.02~beta2-9ubuntu1.17
- Affected ranges
- ECOSYSTEM: < 2.02~beta2-9ubuntu1.20
Update to 2.02~beta2-9ubuntu1.20
grub2-signed Ubuntu:Pro:14.04:LTS
- Versions
- 1.22
- 1.23
- 1.24
- 1.25
- 1.26
- 1.27
- 1.30
- 1.31
- 1.32
- 1.33
- 1.34
- 1.34.1
- 1.34.2
- 1.34.3
- 1.34.4
- 1.34.5
- 1.34.6
- 1.34.7
- 1.34.8
- 1.34.9
- 1.34.13
- 1.34.14
- 1.34.16
- 1.34.17
- 1.34.18
- 1.34.20
- Affected ranges
- ECOSYSTEM: < 1.34.22
Update to 1.34.22
grub2 Ubuntu:16.04:LTS
- Versions
- 2.02~beta2-29
- 2.02~beta2-31
- 2.02~beta2-31ubuntu1
- 2.02~beta2-32
- 2.02~beta2-32ubuntu1
- 2.02~beta2-35
- 2.02~beta2-35ubuntu1
- 2.02~beta2-36
- 2.02~beta2-36ubuntu1
- 2.02~beta2-36ubuntu2
- 2.02~beta2-36ubuntu3
- 2.02~beta2-36ubuntu3.1
- 2.02~beta2-36ubuntu3.2
- 2.02~beta2-36ubuntu3.6
- 2.02~beta2-36ubuntu3.7
- 2.02~beta2-36ubuntu3.8
- 2.02~beta2-36ubuntu3.9
- 2.02~beta2-36ubuntu3.11
- 2.02~beta2-36ubuntu3.12
- 2.02~beta2-36ubuntu3.14
- 2.02~beta2-36ubuntu3.15
- 2.02~beta2-36ubuntu3.16
- 2.02~beta2-36ubuntu3.17
- 2.02~beta2-36ubuntu3.18
- 2.02~beta2-36ubuntu3.19
- 2.02~beta2-36ubuntu3.20
- 2.02~beta2-36ubuntu3.21
- 2.02~beta2-36ubuntu3.22
- 2.02~beta2-36ubuntu3.23
- Affected ranges
- ECOSYSTEM: < 2.02~beta2-36ubuntu3.26
Update to 2.02~beta2-36ubuntu3.26
grub2-signed Ubuntu:16.04:LTS
- Versions
- 1.55
- 1.56
- 1.57
- 1.58
- 1.59
- 1.61
- 1.62
- 1.63
- 1.64
- 1.65
- 1.66
- 1.66.1
- 1.66.2
- 1.66.6
- 1.66.7
- 1.66.8
- 1.66.9
- 1.66.11
- 1.66.12
- 1.66.14
- 1.66.15
- 1.66.16
- 1.66.17
- 1.66.18
- 1.66.19
- 1.66.20
- 1.66.21
- 1.66.22
- 1.66.23
- Affected ranges
- ECOSYSTEM: < 1.66.26
Update to 1.66.26
grub2-unsigned Ubuntu:16.04:LTS
- Versions
- 2.04-1ubuntu44
- 2.04-1ubuntu44.1
- 2.04-1ubuntu44.1.2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
grub2 Ubuntu:18.04:LTS
- Versions
- 2.02~beta3-4ubuntu7
- 2.02-2ubuntu1
- 2.02-2ubuntu2
- 2.02-2ubuntu4
- 2.02-2ubuntu6
- 2.02-2ubuntu7
- 2.02-2ubuntu8
- 2.02-2ubuntu8.1
- 2.02-2ubuntu8.2
- 2.02-2ubuntu8.3
- 2.02-2ubuntu8.4
- 2.02-2ubuntu8.6
- 2.02-2ubuntu8.7
- 2.02-2ubuntu8.9
- 2.02-2ubuntu8.10
- 2.02-2ubuntu8.12
- 2.02-2ubuntu8.13
- 2.02-2ubuntu8.14
- 2.02-2ubuntu8.15
- Affected ranges
- ECOSYSTEM: < 2.02-2ubuntu8.16
Update to 2.02-2ubuntu8.16
grub2-signed Ubuntu:18.04:LTS
- Versions
- 1.85
- 1.86
- 1.87
- 1.89
- 1.91
- 1.92
- 1.93
- 1.93.1
- 1.93.2
- 1.93.3
- 1.93.4
- 1.93.5
- 1.93.7
- 1.93.8
- 1.93.10
- 1.93.11
- 1.93.13
- 1.93.14
- 1.93.15
- 1.93.16
- Affected ranges
- ECOSYSTEM: < 1.93.18
Update to 1.93.18
grub2-unsigned Ubuntu:18.04:LTS
- Versions
- 2.04-1ubuntu44
- 2.04-1ubuntu44.1
- 2.04-1ubuntu44.1.2
- Affected ranges
- ECOSYSTEM: < 2.04-1ubuntu47.4
Update to 2.04-1ubuntu47.4
grub2 Ubuntu:20.04:LTS
- Versions
- 2.04-1ubuntu12
- 2.04-1ubuntu13
- 2.04-1ubuntu14
- 2.04-1ubuntu16
- 2.04-1ubuntu18
- 2.04-1ubuntu20
- 2.04-1ubuntu21
- 2.04-1ubuntu22
- 2.04-1ubuntu23
- 2.04-1ubuntu24
- 2.04-1ubuntu25
- 2.04-1ubuntu26
- Affected ranges
- ECOSYSTEM: < 2.04-1ubuntu26.1
Update to 2.04-1ubuntu26.1
grub2-signed Ubuntu:20.04:LTS
- Versions
- 1.128
- 1.129
- 1.130
- 1.131
- 1.133
- 1.134
- 1.135
- 1.136
- 1.137
- 1.138
- 1.139
- 1.140
- 1.141
- 1.142
- 1.142.1
- Affected ranges
- ECOSYSTEM: < 1.142.3
Update to 1.142.3
grub2-unsigned Ubuntu:20.04:LTS
- Versions
- 2.04-1ubuntu44
- 2.04-1ubuntu44.2
- Affected ranges
- ECOSYSTEM: < 2.04-1ubuntu47.4
Update to 2.04-1ubuntu47.4
Original sources
- https://www.debian.org/security/2020/dsa-4735
- http://www.openwall.com/lists/oss-security/2020/07/29/3
- https://bugzilla.redhat.com/show_bug.cgi?id=1825243
- https://www.kb.cert.org/vuls/id/174059
- https://security.netapp.com/advisory/ntap-20200731-0008/
- https://usn.ubuntu.com/4432-1/
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-grub2-code-exec-xLePCAPY
- http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00017.html
- http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00016.html
- https://eclypsium.com/2020/07/29/theres-a-hole-in-the-boot/
- https://kb.vmware.com/s/article/80181
- https://cve.openeuler.org/#/CVEInfo/CVE-2020-10713
- https://security.gentoo.org/glsa/202104-05
- https://nvd.nist.gov/vuln/detail/CVE-2020-10713