CVE-2020-10738
CVE-2020-10738
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A flaw was found in Moodle versions 3.8 before 3.8.3, 3.7 before 3.7.6, 3.6 before 3.6.10, 3.5 before 3.5.12 and earlier unsupported versions. It was possible to create a SCORM package in such a way that when added to a course, it could be interacted with via web services in order to achieve remote code execution.
CVSS 7.5 · High · EPSS 3.0% · Fix available
- Published
- Updated
Affected products and versions
moodle
- Versions
- 3.8 to 3.8.2: Affected
- 3.7 to 3.7.5: Affected
- 3.6 to 3.6.9: Affected
- 3.5 to 3.5.11: Affected
- Earlier unsupported versions.: Affected
No fix published
moodle/moodle Packagist
- Versions
- v3.8.0
- v3.8.0-beta
- v3.8.0-rc1
- v3.8.1
- v3.8.2
- Affected ranges
- ECOSYSTEM: ≥ 3.8, < 3.8.3
Update to 3.8.3
moodle/moodle Packagist
- Versions
- v3.7.0
- v3.7.0-beta
- v3.7.0-rc1
- v3.7.0-rc2
- v3.7.1
- v3.7.2
- v3.7.3
- v3.7.4
- v3.7.5
- Affected ranges
- ECOSYSTEM: ≥ 3.7, < 3.7.6
Update to 3.7.6
moodle/moodle Packagist
- Versions
- v3.6.0
- v3.6.0-beta
- v3.6.0-rc1
- v3.6.0-rc2
- v3.6.0-rc3
- v3.6.1
- v3.6.2
- v3.6.3
- v3.6.4
- v3.6.5
- v3.6.6
- v3.6.7
- v3.6.8
- v3.6.9
- Affected ranges
- ECOSYSTEM: ≥ 3.6, < 3.6.10
Update to 3.6.10
moodle/moodle Packagist
- Versions
- v3.5.0
- v3.5.0-beta
- v3.5.0-rc1
- v3.5.1
- v3.5.10
- v3.5.11
- v3.5.2
- v3.5.3
- v3.5.4
- v3.5.5
- v3.5.6
- v3.5.7
- v3.5.8
- v3.5.9
- Affected ranges
- ECOSYSTEM: ≥ 3.5, < 3.5.12
Update to 3.5.12
moodle Ubuntu:Pro:16.04:LTS
- Versions
- 2.7.9+dfsg-1
- 2.7.10+dfsg-1
- 2.7.11+dfsg-1
- 2.7.11+dfsg-2
- 2.7.12+dfsg-1
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
moodle Ubuntu:Pro:18.04:LTS
- Versions
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published