CVE-2020-10761
CVE-2020-10761
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An assertion failure issue was found in the Network Block Device(NBD) Server in all QEMU versions before QEMU 5.0.1. This flaw occurs when an nbd-client sends a spec-compliant request that is near the boundary of maximum permitted request length. A remote nbd-client could use this flaw to crash the qemu-nbd server resulting in a denial of service.
CVSS 5.0 · Medium · EPSS 1.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
qemu:
- Versions
- all QEMU versions before QEMU 5.0.1: Affected
No fix published
qemu Debian:12
- Affected ranges
- ECOSYSTEM: < 1:5.0-6
Update to 1:5.0-6
qemu Debian:13
- Affected ranges
- ECOSYSTEM: < 1:5.0-6
Update to 1:5.0-6
qemu Debian:14
- Affected ranges
- ECOSYSTEM: < 1:5.0-6
Update to 1:5.0-6
qemu Ubuntu:20.04:LTS
- Versions
- 1:4.0+dfsg-0ubuntu9
- 1:4.0+dfsg-0ubuntu10
- 1:4.2-1ubuntu1
- 1:4.2-1ubuntu2
- 1:4.2-3ubuntu1
- 1:4.2-3ubuntu2
- 1:4.2-3ubuntu3
- 1:4.2-3ubuntu4
- 1:4.2-3ubuntu5
- 1:4.2-3ubuntu6
- 1:4.2-3ubuntu6.1
- 1:4.2-3ubuntu6.2
- 1:4.2-3ubuntu6.3
- Affected ranges
- ECOSYSTEM: < 1:4.2-3ubuntu6.4
Update to 1:4.2-3ubuntu6.4
Original sources
- https://www.openwall.com/lists/oss-security/2020/06/09/1
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-10761
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00086.html
- https://security.netapp.com/advisory/ntap-20200731-0001/
- https://usn.ubuntu.com/4467-1/
- https://security.gentoo.org/glsa/202011-09
- https://nvd.nist.gov/vuln/detail/CVE-2020-10761