CVE-2020-11030
CVE-2020-11030 · Cross-site scripting (XSS) in Search block in WordPress
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In affected versions of WordPress, a special payload can be crafted that can lead to scripts getting executed within the search block of the block editor. This requires an authenticated user with the ability to add content. This has been patched in version 5.4.1, along with all the previously affected versions via a minor release (5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18, 4.5.21, 4.4.22, 4.3.23, 4.2.27, 4.1.30, 4.0.30, 3.9.31, 3.8.33, 3.7.33).
CVSS 6.4 · Medium · EPSS 1.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
wordpress
- Versions
- >= 5.4.0, < 5.4.1: Affected
- >= 5.3.0, < 5.3.3: Affected
- >= 5.2.0, < 5.2.6: Affected
- >= 5.1.0, < 5.1.5: Affected
- >= 5.0.0, < 5.0.9: Affected
- >= 4.9.0, < 4.9.14: Affected
- >= 4.8.0, < 4.8.13: Affected
- >= 4.7.0, < 4.7.17: Affected
- >= 4.6.0, < 4.6.18: Affected
- >= 4.5.0, < 4.5.21: Affected
- >= 4.4.0, < 4.4.22: Affected
- >= 4.3.0, < 4.3.23: Affected
- >= 4.2.0, < 4.2.27: Affected
- >= 4.1.0, < 4.1.30: Affected
- >= 4.0.0, < 4.0.30: Affected
- >= 3.9.0, < 3.9.31: Affected
- >= 3.8.0, < 3.8.33: Affected
- >= 3.7.0, < 3.7.33: Affected
No fix published
wordpress Debian:12
- Affected ranges
- ECOSYSTEM: < 5.4.1+dfsg1-1
Update to 5.4.1+dfsg1-1
wordpress Debian:13
- Affected ranges
- ECOSYSTEM: < 5.4.1+dfsg1-1
Update to 5.4.1+dfsg1-1
wordpress Debian:14
- Affected ranges
- ECOSYSTEM: < 5.4.1+dfsg1-1
Update to 5.4.1+dfsg1-1
wordpress Ubuntu:16.04:LTS
- Versions
- 4.3+dfsg-1
- 4.3.1+dfsg-1
- 4.4+dfsg-1
- 4.4.1+dfsg-1
- 4.4.2+dfsg-1
- 4.4.2+dfsg-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:18.04:LTS
- Versions
- 4.8.2+dfsg-2
- 4.8.3+dfsg-1
- 4.9.1+dfsg-1
- 4.9.2+dfsg-1
- 4.9.4+dfsg-1
- 4.9.5+dfsg1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:20.04:LTS
- Versions
- 5.2.2+dfsg1-1
- 5.2.4+dfsg1-1
- 5.3.2+dfsg1-1
- 5.3.2+dfsg1-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:22.04:LTS
- Versions
- 5.7.1+dfsg1-2ubuntu1
- 5.8.1+dfsg1-2ubuntu1
- 5.8.2+dfsg1-1ubuntu1
- 5.8.3+dfsg1-1ubuntu1
- 5.8.3+dfsg1-1ubuntu1.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:24.04:LTS
- Versions
- 6.2+dfsg1-1ubuntu1
- 6.4.3+dfsg1-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:25.10
- Versions
- 6.7.2+dfsg1-1.1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:26.10
- Versions
- 6.7.2+dfsg1-1.1ubuntu2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:26.04:LTS
- Versions
- 6.7.2+dfsg1-1.1ubuntu1
- 6.7.2+dfsg1-1.1ubuntu2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published