p PatchFirst

CVE-2020-11065

CVE-2020-11065 · Cross-Site Scripting in TYPO3 CMS

This page contains facts from public vulnerability sources. Check the original advisory before updating.

In TYPO3 CMS greater than or equal to 9.5.12 and less than 9.5.17, and greater than or equal to 10.2.0 and less than 10.4.2, it has been discovered that link tags generated by typolink functionality are vulnerable to cross-site scripting; properties being assigned as HTML attributes have not been parsed correctly. This has been fixed in 9.5.17 and 10.4.2.

CVSS 5.4 · Medium · EPSS 0.5% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • typo3 cms

    Versions
    • >= 9.5.12, < 9.5.17: Affected
    • >= 10.2.0, < 10.4.2: Affected

    No fix published

  • typo3/cms-core Packagist

    Versions
    • v10.0.0
    • v10.1.0
    • v10.2.0
    • v10.2.1
    • v10.2.2
    • v10.3.0
    • v10.4.0
    • v10.4.1
    Affected ranges
    • ECOSYSTEM: ≥ 10.0.0, < 10.4.2

    Update to 10.4.2

  • typo3/cms-core Packagist

    Versions
    • v9.0.0
    • v9.1.0
    • v9.2.0
    • v9.2.1
    • v9.3.0
    • v9.3.1
    • v9.3.2
    • v9.3.3
    • v9.4.0
    • v9.5.0
    • v9.5.1
    • v9.5.10
    • v9.5.11
    • v9.5.12
    • v9.5.13
    • v9.5.14
    • v9.5.15
    • v9.5.16
    • v9.5.2
    • v9.5.3
    • v9.5.4
    • v9.5.5
    • v9.5.6
    • v9.5.7
    • v9.5.8
    • v9.5.9
    Affected ranges
    • ECOSYSTEM: ≥ 9.0.0, < 9.5.17

    Update to 9.5.17

  • typo3/cms Packagist

    Versions
    • v10.0.0
    • v10.1.0
    • v10.2.0
    • v10.2.1
    • v10.2.2
    • v10.3.0
    • v10.4.0
    • v10.4.1
    Affected ranges
    • ECOSYSTEM: ≥ 10.0.0, < 10.4.2

    Update to 10.4.2

  • typo3/cms Packagist

    Versions
    • v9.0.0
    • v9.1.0
    • v9.2.0
    • v9.2.1
    • v9.3.0
    • v9.3.1
    • v9.3.2
    • v9.3.3
    • v9.4.0
    • v9.5.0
    • v9.5.1
    • v9.5.10
    • v9.5.11
    • v9.5.12
    • v9.5.13
    • v9.5.14
    • v9.5.15
    • v9.5.16
    • v9.5.2
    • v9.5.3
    • v9.5.4
    • v9.5.5
    • v9.5.6
    • v9.5.7
    • v9.5.8
    • v9.5.9
    Affected ranges
    • ECOSYSTEM: ≥ 9.0.0, < 9.5.17

    Update to 9.5.17

Original sources

Check your server →