p PatchFirst

CVE-2020-11501

CVE-2020-11501

This page contains facts from public vulnerability sources. Check the original advisory before updating.

GnuTLS 3.6.x before 3.6.13 uses incorrect cryptography for DTLS. The earliest affected version is 3.6.3 (2018-07-16) because of an error in a 2017-10-06 commit. The DTLS client always uses 32 '\0' bytes instead of a random value, and thus contributes no randomness to a DTLS negotiation. This breaks the security guarantees of the DTLS protocol.

EPSS 3.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • gnutls28 Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.6.13-2

    Update to 3.6.13-2

  • gnutls28 Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.6.13-2

    Update to 3.6.13-2

  • gnutls28 Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.6.13-2

    Update to 3.6.13-2

Original sources

Check your server →