CVE-2020-11981
CVE-2020-11981
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An issue was found in Apache Airflow versions 1.10.10 and below. When using CeleryExecutor, if an attacker can connect to the broker (Redis, RabbitMQ) directly, it is possible to inject commands, resulting in the celery worker running arbitrary commands.
CVSS 9.8 · Critical · EPSS 36.8% · Public exploit · Fix available
- Published
- Updated
Stack: python
Affected products and versions
apache airflow
- Versions
- 1.10.10 and below: Affected
No fix published
apache-airflow PyPI
- Versions
- 1.10.0
- 1.10.1
- 1.10.10
- 1.10.10rc1
- 1.10.10rc2
- 1.10.10rc3
- 1.10.10rc4
- 1.10.10rc5
- 1.10.1b1
- 1.10.1rc2
- 1.10.2
- 1.10.2b2
- 1.10.2rc1
- 1.10.2rc2
- 1.10.2rc3
- 1.10.3
- 1.10.3b1
- 1.10.3b2
- 1.10.3rc1
- 1.10.3rc2
- 1.10.4
- 1.10.4b2
- 1.10.4rc1
- 1.10.4rc2
- 1.10.4rc3
- 1.10.4rc4
- 1.10.4rc5
- 1.10.5
- 1.10.5rc1
- 1.10.6
- 1.10.6rc1
- 1.10.6rc2
- 1.10.7
- 1.10.7rc1
- 1.10.7rc2
- 1.10.7rc3
- 1.10.8
- 1.10.8rc1
- 1.10.9
- 1.10.9rc1
- 1.8.1
- 1.8.2
- 1.8.2rc1
- 1.9.0
- Affected ranges
- ECOSYSTEM: < 1.10.11rc1
Update to 1.10.11rc1
apache-airflow PyPI
- Versions
- 1.8.1
- 1.8.2rc1
- 1.8.2
- 1.9.0
- 1.10.0
- 1.10.1b1
- 1.10.1rc2
- 1.10.1
- 1.10.2b2
- 1.10.2rc1
- 1.10.2rc2
- 1.10.2rc3
- 1.10.2
- 1.10.3b1
- 1.10.3b2
- 1.10.3rc1
- 1.10.3rc2
- 1.10.3
- 1.10.4b2
- 1.10.4rc1
- 1.10.4rc2
- 1.10.4rc3
- 1.10.4rc4
- 1.10.4rc5
- 1.10.4
- 1.10.5rc1
- 1.10.5
- 1.10.6rc1
- 1.10.6rc2
- 1.10.6
- 1.10.7rc1
- 1.10.7rc2
- 1.10.7rc3
- 1.10.7
- 1.10.8rc1
- 1.10.8
- 1.10.9rc1
- 1.10.9
- 1.10.10rc1
- 1.10.10rc2
- 1.10.10rc3
- 1.10.10rc4
- 1.10.10rc5
- 1.10.10
- Affected ranges
- ECOSYSTEM: < 1.10.11rc1
Update to 1.10.11rc1