p PatchFirst

CVE-2020-12640

CVE-2020-12640

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Roundcube Webmail before 1.4.4 allows attackers to include local files and execute code via directory traversal in a plugin name to rcube_plugin_api.php.

CVSS 9.8 · Critical · EPSS 6.7% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • roundcube Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.4.4+dfsg.1-1

    Update to 1.4.4+dfsg.1-1

  • roundcube Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.4.4+dfsg.1-1

    Update to 1.4.4+dfsg.1-1

  • roundcube Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.4.4+dfsg.1-1

    Update to 1.4.4+dfsg.1-1

  • roundcube Ubuntu:Pro:16.04:LTS

    Versions
    • 1.1.1+dfsg.1-2
    • 1.1.2+dfsg.1-5
    • 1.1.3+dfsg.1-1
    • 1.1.4+dfsg.1-1
    • 1.2~beta+dfsg.1-0ubuntu1
    • 1.2~beta+dfsg.1-0ubuntu1+esm1
    Affected ranges
    • ECOSYSTEM: < 1.2~beta+dfsg.1-0ubuntu1+esm2

    Update to 1.2~beta+dfsg.1-0ubuntu1+esm2

  • roundcube Ubuntu:Pro:18.04:LTS

    Versions
    • 1.3.0+dfsg.1-1
    • 1.3.1+dfsg.1-1
    • 1.3.3+dfsg.1-1
    • 1.3.3+dfsg.1-2
    • 1.3.6+dfsg.1-1
    • 1.3.6+dfsg.1-1ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: < 1.3.6+dfsg.1-1ubuntu0.1~esm2

    Update to 1.3.6+dfsg.1-1ubuntu0.1~esm2

  • roundcube Ubuntu:Pro:20.04:LTS

    Versions
    • 1.3.8+dfsg.1-2
    • 1.3.10+dfsg.1-1
    • 1.4.1+dfsg.1-2
    • 1.4.2+dfsg.1-1
    • 1.4.2+dfsg.1-2
    • 1.4.3+dfsg.1-1
    Affected ranges
    • ECOSYSTEM: < 1.4.3+dfsg.1-1ubuntu0.1~esm1

    Update to 1.4.3+dfsg.1-1ubuntu0.1~esm1

Original sources

Check your server →