p PatchFirst

CVE-2020-13777

CVE-2020-13777

This page contains facts from public vulnerability sources. Check the original advisory before updating.

GnuTLS 3.6.x before 3.6.14 uses incorrect cryptography for encrypting a session ticket (a loss of confidentiality in TLS 1.2, and an authentication bypass in TLS 1.3). The earliest affected version is 3.6.4 (2018-09-24) because of an error in a 2018-09-18 commit. Until the first key rotation, the TLS server always uses wrong data in place of an encryption key derived from an application.

CVSS 7.4 · High · EPSS 22.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • gnutls28 Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.6.14-1

    Update to 3.6.14-1

  • gnutls28 Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.6.14-1

    Update to 3.6.14-1

  • gnutls28 Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.6.14-1

    Update to 3.6.14-1

  • gnutls28 Ubuntu:20.04:LTS

    Versions
    • 3.6.9-5ubuntu1
    • 3.6.9-5ubuntu2
    • 3.6.10-5
    • 3.6.11.1-2
    • 3.6.11.1-2ubuntu2
    • 3.6.13-2ubuntu1
    Affected ranges
    • ECOSYSTEM: < 3.6.13-2ubuntu1.1

    Update to 3.6.13-2ubuntu1.1

Original sources

Check your server →