CVE-2020-13817
CVE-2020-13817
This page contains facts from public vulnerability sources. Check the original advisory before updating.
ntpd in ntp before 4.2.8p14 and 4.3.x before 4.3.100 allows remote attackers to cause a denial of service (daemon exit or system time change) by predicting transmit timestamps for use in spoofed packets. The victim must be relying on unauthenticated IPv4 time sources. There must be an off-path attacker who can query time from the victim's ntpd instance.
CVSS 7.4 · High · EPSS 3.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
ntp Debian:11
- Affected ranges
- ECOSYSTEM: < 1:4.2.8p14+dfsg-1
Update to 1:4.2.8p14+dfsg-1
ntp Ubuntu:Pro:14.04:LTS
- Versions
- 1:4.2.6.p5+dfsg-3ubuntu2
- 1:4.2.6.p5+dfsg-3ubuntu2.14.04.1
- 1:4.2.6.p5+dfsg-3ubuntu2.14.04.2
- 1:4.2.6.p5+dfsg-3ubuntu2.14.04.3
- 1:4.2.6.p5+dfsg-3ubuntu2.14.04.5
- 1:4.2.6.p5+dfsg-3ubuntu2.14.04.6
- 1:4.2.6.p5+dfsg-3ubuntu2.14.04.7
- 1:4.2.6.p5+dfsg-3ubuntu2.14.04.8
- 1:4.2.6.p5+dfsg-3ubuntu2.14.04.10
- 1:4.2.6.p5+dfsg-3ubuntu2.14.04.11
- 1:4.2.6.p5+dfsg-3ubuntu2.14.04.12
- 1:4.2.6.p5+dfsg-3ubuntu2.14.04.13
- 1:4.2.6.p5+dfsg-3ubuntu2.14.04.13+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ntp Ubuntu:16.04:LTS
- Versions
- 1:4.2.6.p5+dfsg-3ubuntu8
- 1:4.2.6.p5+dfsg-3ubuntu8.1
- 1:4.2.6.p5+dfsg-3ubuntu9
- 1:4.2.8p4+dfsg-3ubuntu1
- 1:4.2.8p4+dfsg-3ubuntu2
- 1:4.2.8p4+dfsg-3ubuntu3
- 1:4.2.8p4+dfsg-3ubuntu4
- 1:4.2.8p4+dfsg-3ubuntu5
- 1:4.2.8p4+dfsg-3ubuntu5.1
- 1:4.2.8p4+dfsg-3ubuntu5.2
- 1:4.2.8p4+dfsg-3ubuntu5.3
- 1:4.2.8p4+dfsg-3ubuntu5.4
- 1:4.2.8p4+dfsg-3ubuntu5.5
- 1:4.2.8p4+dfsg-3ubuntu5.6
- 1:4.2.8p4+dfsg-3ubuntu5.7
- 1:4.2.8p4+dfsg-3ubuntu5.8
- 1:4.2.8p4+dfsg-3ubuntu5.9
- 1:4.2.8p4+dfsg-3ubuntu5.10
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ntp Ubuntu:Pro:18.04:LTS
- Versions
- 1:4.2.8p10+dfsg-5ubuntu3
- 1:4.2.8p10+dfsg-5ubuntu4
- 1:4.2.8p10+dfsg-5ubuntu5
- 1:4.2.8p10+dfsg-5ubuntu6
- 1:4.2.8p10+dfsg-5ubuntu7
- 1:4.2.8p10+dfsg-5ubuntu7.1
- 1:4.2.8p10+dfsg-5ubuntu7.1+esm1
- 1:4.2.8p10+dfsg-5ubuntu7.1+esm2
- 1:4.2.8p10+dfsg-5ubuntu7.2
- 1:4.2.8p10+dfsg-5ubuntu7.2+esm1
- 1:4.2.8p10+dfsg-5ubuntu7.3
- 1:4.2.8p10+dfsg-5ubuntu7.3+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ntp Ubuntu:Pro:20.04:LTS
- Versions
- 1:4.2.8p12+dfsg-3ubuntu2
- 1:4.2.8p12+dfsg-3ubuntu3
- 1:4.2.8p12+dfsg-3ubuntu4
- 1:4.2.8p12+dfsg-3ubuntu4.20.04.1
- 1:4.2.8p12+dfsg-3ubuntu4.20.04.1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ntp Ubuntu:22.04:LTS
- Versions
- 1:4.2.8p12+dfsg-3ubuntu6
- 1:4.2.8p15+dfsg-1ubuntu1
- 1:4.2.8p15+dfsg-1ubuntu2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00005.html
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00044.html
- https://security.gentoo.org/glsa/202007-12
- https://www.oracle.com/security-alerts/cpujan2022.html
- http://support.ntp.org/bin/view/Main/NtpBug3596
- https://bugs.ntp.org/show_bug.cgi?id=3596
- https://security.netapp.com/advisory/ntap-20200625-0004/
- https://nvd.nist.gov/vuln/detail/CVE-2020-13817