p PatchFirst

CVE-2020-14154

CVE-2020-14154

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Mutt before 1.14.3 proceeds with a connection even if, in response to a GnuTLS certificate prompt, the user rejects an expired intermediate certificate.

CVSS 4.8 · Medium · EPSS 1.1% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • mutt Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.14.3-1

    Update to 1.14.3-1

  • mutt Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.14.3-1

    Update to 1.14.3-1

  • mutt Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.14.3-1

    Update to 1.14.3-1

  • neomutt Debian:12

    Affected ranges
    • ECOSYSTEM: < 20200619+dfsg.1-1

    Update to 20200619+dfsg.1-1

  • neomutt Debian:13

    Affected ranges
    • ECOSYSTEM: < 20200619+dfsg.1-1

    Update to 20200619+dfsg.1-1

  • neomutt Debian:14

    Affected ranges
    • ECOSYSTEM: < 20200619+dfsg.1-1

    Update to 20200619+dfsg.1-1

  • mutt Ubuntu:16.04:LTS

    Versions
    • 1.5.23-3.1ubuntu1
    • 1.5.23-3.1ubuntu2
    • 1.5.24-1
    • 1.5.24-1build1
    • 1.5.24-1ubuntu0.1
    • 1.5.24-1ubuntu0.2
    Affected ranges
    • ECOSYSTEM: < 1.5.24-1ubuntu0.3

    Update to 1.5.24-1ubuntu0.3

  • mutt Ubuntu:18.04:LTS

    Versions
    • 1.8.3+neomutt20170609-2build1
    • 1.9.1-2
    • 1.9.1-3
    • 1.9.1-4
    • 1.9.1-5
    • 1.9.2-1
    • 1.9.3-1
    • 1.9.4-2
    • 1.9.4-3
    • 1.9.4-3ubuntu0.1
    Affected ranges
    • ECOSYSTEM: < 1.9.4-3ubuntu0.2

    Update to 1.9.4-3ubuntu0.2

  • mutt Ubuntu:20.04:LTS

    Versions
    • 1.10.1-2.1
    • 1.12.2-1
    • 1.12.2-2
    • 1.13.0-1
    • 1.13.2-1
    Affected ranges
    • ECOSYSTEM: < 1.13.2-1ubuntu0.1

    Update to 1.13.2-1ubuntu0.1

Original sources

Check your server →