p PatchFirst

CVE-2020-14400

CVE-2020-14400

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue was discovered in LibVNCServer before 0.9.13. Byte-aligned data is accessed through uint16_t pointers in libvncserver/translate.c. NOTE: Third parties do not consider this to be a vulnerability as there is no known path of exploitation or cross of a trust boundary

CVSS 7.5 · High · EPSS 2.8% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libvncserver Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.9.13+dfsg-1

    Update to 0.9.13+dfsg-1

  • libvncserver Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.9.13+dfsg-1

    Update to 0.9.13+dfsg-1

  • libvncserver Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.9.13+dfsg-1

    Update to 0.9.13+dfsg-1

  • libvncserver Ubuntu:16.04:LTS

    Versions
    • 0.9.10+dfsg-3
    • 0.9.10+dfsg-3build1
    • 0.9.10+dfsg-3ubuntu0.16.04.1
    • 0.9.10+dfsg-3ubuntu0.16.04.2
    • 0.9.10+dfsg-3ubuntu0.16.04.3
    • 0.9.10+dfsg-3ubuntu0.16.04.4
    Affected ranges
    • ECOSYSTEM: < 0.9.10+dfsg-3ubuntu0.16.04.5

    Update to 0.9.10+dfsg-3ubuntu0.16.04.5

  • libvncserver Ubuntu:18.04:LTS

    Versions
    • 0.9.11+dfsg-1
    • 0.9.11+dfsg-1ubuntu1
    • 0.9.11+dfsg-1ubuntu1.1
    • 0.9.11+dfsg-1ubuntu1.2
    Affected ranges
    • ECOSYSTEM: < 0.9.11+dfsg-1ubuntu1.3

    Update to 0.9.11+dfsg-1ubuntu1.3

  • libvncserver Ubuntu:20.04:LTS

    Versions
    • 0.9.11+dfsg-1.3
    • 0.9.12+dfsg-3ubuntu3
    • 0.9.12+dfsg-6
    • 0.9.12+dfsg-7
    • 0.9.12+dfsg-8
    • 0.9.12+dfsg-9
    • 0.9.12+dfsg-9ubuntu0.1
    Affected ranges
    • ECOSYSTEM: < 0.9.12+dfsg-9ubuntu0.2

    Update to 0.9.12+dfsg-9ubuntu0.2

Original sources

Check your server →