p PatchFirst

CVE-2020-15118

CVE-2020-15118 · Cross-Site Scripting in Wagtail

This page contains facts from public vulnerability sources. Check the original advisory before updating.

In Wagtail before versions 2.7.4 and 2.9.3, when a form page type is made available to Wagtail editors through the `wagtail.contrib.forms` app, and the page template is built using Django's standard form rendering helpers such as form.as_p, any HTML tags used within a form field's help text will be rendered unescaped in the page. Allowing HTML within help text is an intentional design decision by Django; however, as a matter of policy Wagtail does not allow editors to insert arbitrary HTML by default, as this could potentially be used to carry out cross-site scripting attacks, including privilege escalation. This functionality should therefore not have been made available to editor-level users. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. Patched versions have been released as Wagtail 2.7.4 (for the LTS 2.7 branch) and Wagtail 2.9.3 (for the current 2.9 branch). In these versions, help text will be escaped to prevent the inclusion of HTML tags. Site owners who wish to re-enable the use of HTML within help text (and are willing to accept the risk of this being exploited by editors) may set WAGTAILFORMS_HELP_TEXT_ALLOW_HTML = True in their configuration settings. Site owners who are unable to upgrade to the new versions can secure their form page templates by rendering forms field-by-field as per Django's documentation, but omitting the |safe filter when outputting the help text.

CVSS 5.7 · Medium · EPSS 1.1% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • wagtail

    Versions
    • < 2.7.4: Affected
    • >= 2.8.0, < 2.9.3: Affected

    No fix published

  • wagtail PyPI

    Versions
    • 2.8
    • 2.8.1
    • 2.8.2
    • 2.8rc1
    • 2.9
    • 2.9.1
    • 2.9.2
    • 2.9rc1
    Affected ranges
    • ECOSYSTEM: ≥ 2.8rc1, < 2.9.3

    Update to 2.9.3

  • wagtail PyPI

    Versions
    • 0.1
    • 0.2
    • 0.3
    • 0.3.1
    • 0.4
    • 0.4.1
    • 0.5
    • 0.6
    • 0.7
    • 0.8
    • 0.8.1
    • 0.8.10
    • 0.8.2
    • 0.8.3
    • 0.8.4
    • 0.8.5
    • 0.8.6
    • 0.8.7
    • 0.8.8
    • 0.8.9
    • 1.0
    • 1.0b1
    • 1.0b2
    • 1.0rc1
    • 1.0rc2
    • 1.1
    • 1.10
    • 1.10.1
    • 1.10rc1
    • 1.11
    • 1.11.1
    • 1.11rc1
    • 1.12
    • 1.12.1
    • 1.12.2
    • 1.12.3
    • 1.12.4
    • 1.12.5
    • 1.12.6
    • 1.12rc1
    • 1.13
    • 1.13.1
    • 1.13.2
    • 1.13.3
    • 1.13.4
    • 1.13rc1
    • 1.1rc1
    • 1.2
    • 1.2rc1
    • 1.3
    • 1.3.1
    • 1.3rc1
    • 1.4
    • 1.4.1
    • 1.4.2
    • 1.4.3
    • 1.4.4
    • 1.4.5
    • 1.4.6
    • 1.4rc1
    • 1.5
    • 1.5.1
    • 1.5.2
    • 1.5.3
    • 1.5rc1
    • 1.6
    • 1.6.1
    • 1.6.2
    • 1.6.3
    • 1.6rc1
    • 1.7
    • 1.7rc1
    • 1.8
    • 1.8.1
    • 1.8.2
    • 1.8rc1
    • 1.9
    • 1.9.1
    • 1.9rc1
    • 2.0
    • 2.0.1
    • 2.0.2
    • 2.0b1
    • 2.0rc1
    • 2.1
    • 2.1.1
    • 2.1.2
    • 2.1.3
    • 2.1rc1
    • 2.1rc2
    • 2.2
    • 2.2.1
    • 2.2.2
    • 2.2rc1
    • 2.2rc2
    • 2.3
    • 2.3rc1
    • 2.3rc2
    • 2.4
    • 2.4rc1
    • 2.5
    • 2.5.1
    • 2.5.2
    • 2.5rc1
    • 2.6
    • 2.6.1
    • 2.6.2
    • 2.6.3
    • 2.6rc1
    • 2.7
    • 2.7.1
    • 2.7.2
    • 2.7.3
    • 2.7rc1
    • 2.7rc2
    Affected ranges
    • ECOSYSTEM: < 2.7.4

    Update to 2.7.4

  • wagtail PyPI

    Versions
    • 2.7
    • 2.7.1
    • 2.7.2
    • 2.7.3
    • 2.9
    • 2.9.1
    • 2.9.2
    Affected ranges
    • GIT: < d9a41e7f24d08c024acc9a3094940199df94db34
    • ECOSYSTEM: ≥ 2.7, < 2.7.4 ∪ ≥ 2.9, < 2.9.3

    Update to 2.7.4; Update to 2.9.3

Original sources

Check your server →