CVE-2020-15142
CVE-2020-15142 · Arbitrary Code Generation
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In openapi-python-client before version 0.5.3, clients generated with a maliciously crafted OpenAPI Document can generate arbitrary Python code. Subsequent execution of this malicious client is arbitrary code execution.
CVSS 8.0 · High · EPSS 1.8% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
openapi-python-client
- Versions
- < 0.5.3: Affected
No fix published
openapi-python-client PyPI
- Versions
- 0.1.0
- 0.1.0.dev0
- 0.1.1
- 0.1.2
- 0.2.0
- 0.2.1
- 0.3.0
- 0.4.0
- 0.4.0rc1
- 0.4.1
- 0.4.2
- 0.5.0
- 0.5.1
- 0.5.2
- Affected ranges
- ECOSYSTEM: < 0.5.3
Update to 0.5.3
openapi-python-client PyPI
- Versions
- 0.1.0.dev0
- 0.1.0
- 0.1.1
- 0.1.2
- 0.2.0
- 0.2.1
- 0.3.0
- 0.4.0rc1
- 0.4.0
- 0.4.1
- 0.4.2
- 0.5.0
- 0.5.1
- 0.5.2
- Affected ranges
- GIT: < f7a56aae32cba823a77a84a1f10400799b19c19a
- ECOSYSTEM: < 0.5.3
Update to 0.5.3
Original sources
- https://github.com/triaxtec/openapi-python-client/security/advisories/GHSA-9x4c-63pf-525f
- https://github.com/triaxtec/openapi-python-client/commit/f7a56aae32cba823a77a84a1f10400799b19c19a
- https://github.com/triaxtec/openapi-python-client/blob/main/CHANGELOG.md#053---2020-08-13
- https://pypi.org/project/openapi-python-client/
- https://nvd.nist.gov/vuln/detail/CVE-2020-15142