CVE-2020-15194
CVE-2020-15194 · Denial of Service in Tensorflow
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In Tensorflow before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, the `SparseFillEmptyRowsGrad` implementation has incomplete validation of the shapes of its arguments. Although `reverse_index_map_t` and `grad_values_t` are accessed in a similar pattern, only `reverse_index_map_t` is validated to be of proper shape. Hence, malicious users can pass a bad `grad_values_t` to trigger an assertion failure in `vec`, causing denial of service in serving installations. The issue is patched in commit 390611e0d45c5793c7066110af37c8514e6a6c54, and is released in TensorFlow versions 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1."
CVSS 5.3 · Medium · EPSS 1.0% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
tensorflow
- Versions
- < 1.15.4: Affected
- >= 2.0.0, < 2.0.3: Affected
- >= 2.1.0, < 2.1.2: Affected
- >= 2.2.0, < 2.2.1: Affected
- >= 2.3.0, < 2.3.1: Affected
No fix published
tensorflow PyPI
- Versions
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.10.1
- 1.11.0
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.1
- 1.13.2
- 1.14.0
- 1.15.0
- 1.15.2
- 1.15.3
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- Affected ranges
- ECOSYSTEM: < 1.15.4
Update to 1.15.4
tensorflow PyPI
- Versions
- 2.0.0
- 2.0.1
- 2.0.2
- Affected ranges
- ECOSYSTEM: ≥ 2.0.0, < 2.0.3
Update to 2.0.3
tensorflow PyPI
- Versions
- 2.1.0
- 2.1.1
- Affected ranges
- ECOSYSTEM: ≥ 2.1.0, < 2.1.2
Update to 2.1.2
tensorflow PyPI
- Versions
- 2.2.0
- Affected ranges
- ECOSYSTEM: ≥ 2.2.0, < 2.2.1
Update to 2.2.1
tensorflow PyPI
- Versions
- 2.3.0
- Affected ranges
- ECOSYSTEM: ≥ 2.3.0, < 2.3.1
Update to 2.3.1
tensorflow-cpu PyPI
- Versions
- 1.15.0
- Affected ranges
- ECOSYSTEM: < 1.15.4
Update to 1.15.4
tensorflow-cpu PyPI
- Affected ranges
- ECOSYSTEM: ≥ 2.0.0, < 2.0.3
Update to 2.0.3
tensorflow-cpu PyPI
- Versions
- 2.1.0
- 2.1.1
- Affected ranges
- ECOSYSTEM: ≥ 2.1.0, < 2.1.2
Update to 2.1.2
tensorflow-cpu PyPI
- Versions
- 2.2.0
- Affected ranges
- ECOSYSTEM: ≥ 2.2.0, < 2.2.1
Update to 2.2.1
tensorflow-cpu PyPI
- Versions
- 2.3.0
- Affected ranges
- ECOSYSTEM: ≥ 2.3.0, < 2.3.1
Update to 2.3.1
tensorflow-gpu PyPI
- Versions
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.10.1
- 1.11.0
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.1
- 1.13.2
- 1.14.0
- 1.15.0
- 1.15.2
- 1.15.3
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- Affected ranges
- ECOSYSTEM: < 1.15.4
Update to 1.15.4
tensorflow-gpu PyPI
- Versions
- 2.0.0
- 2.0.1
- 2.0.2
- Affected ranges
- ECOSYSTEM: ≥ 2.0.0, < 2.0.3
Update to 2.0.3
tensorflow-gpu PyPI
- Versions
- 2.1.0
- 2.1.1
- Affected ranges
- ECOSYSTEM: ≥ 2.1.0, < 2.1.2
Update to 2.1.2
tensorflow-gpu PyPI
- Versions
- 2.2.0
- Affected ranges
- ECOSYSTEM: ≥ 2.2.0, < 2.2.1
Update to 2.2.1
tensorflow-gpu PyPI
- Versions
- 2.3.0
- Affected ranges
- ECOSYSTEM: ≥ 2.3.0, < 2.3.1
Update to 2.3.1
tensorflow PyPI
- Versions
- 0.12.0rc0
- 0.12.0rc1
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0rc0
- 1.1.0rc1
- 1.1.0rc2
- 1.1.0
- 1.2.0rc0
- 1.2.0rc1
- 1.2.0rc2
- 1.2.0
- 1.2.1
- 1.3.0rc0
- 1.3.0rc1
- 1.3.0rc2
- 1.3.0
- 1.4.0rc0
- 1.4.0rc1
- 1.4.0
- 1.4.1
- 1.5.0rc0
- 1.5.0rc1
- 1.5.0
- 1.5.1
- 1.6.0rc0
- 1.6.0rc1
- 1.6.0
- 1.7.0rc0
- 1.7.0rc1
- 1.7.0
- 1.7.1
- 1.8.0rc0
- 1.8.0rc1
- 1.8.0
- 1.9.0rc0
- 1.9.0rc1
- 1.9.0rc2
- 1.9.0
- 1.10.0rc0
- 1.10.0rc1
- 1.10.0
- 1.10.1
- 1.11.0rc0
- 1.11.0rc1
- 1.11.0rc2
- 1.11.0
- 1.12.0rc0
- 1.12.0rc1
- 1.12.0rc2
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.0rc0
- 1.13.0rc1
- 1.13.0rc2
- 1.13.1
- 1.13.2
- 1.14.0rc0
- 1.14.0rc1
- 1.14.0
- 1.15.0rc0
- 1.15.0rc1
- 1.15.0rc2
- 1.15.0rc3
- 1.15.0
- 1.15.2
- 1.15.3
- 2.0.0
- 2.0.1
- 2.0.2
- 2.1.0
- 2.1.1
- 2.2.0
- 2.3.0
- Affected ranges
- GIT: < 390611e0d45c5793c7066110af37c8514e6a6c54
- ECOSYSTEM: < 1.15.4 ∪ ≥ 2.0.0, < 2.0.3 ∪ ≥ 2.1.0, < 2.1.2 ∪ ≥ 2.2.0, < 2.2.1 ∪ ≥ 2.3.0, < 2.3.1
Update to 1.15.4; Update to 2.0.3; Update to 2.1.2; Update to 2.2.1; Update to 2.3.1
tensorflow-cpu PyPI
- Versions
- 1.15.0
- 2.1.0
- 2.1.1
- 2.2.0
- 2.3.0
- Affected ranges
- GIT: < 390611e0d45c5793c7066110af37c8514e6a6c54
- ECOSYSTEM: < 1.15.4 ∪ ≥ 2.0.0, < 2.0.3 ∪ ≥ 2.1.0, < 2.1.2 ∪ ≥ 2.2.0, < 2.2.1 ∪ ≥ 2.3.0, < 2.3.1
Update to 1.15.4; Update to 2.0.3; Update to 2.1.2; Update to 2.2.1; Update to 2.3.1
tensorflow-gpu PyPI
- Versions
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.10.1
- 1.11.0
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.1
- 1.13.2
- 1.14.0
- 1.15.0
- 1.15.2
- 1.15.3
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- 2.0.0
- 2.0.1
- 2.0.2
- 2.1.0
- 2.1.1
- 2.2.0
- 2.3.0
- Affected ranges
- GIT: < 390611e0d45c5793c7066110af37c8514e6a6c54
- ECOSYSTEM: < 1.15.4 ∪ ≥ 2.0.0, < 2.0.3 ∪ ≥ 2.1.0, < 2.1.2 ∪ ≥ 2.2.0, < 2.2.1 ∪ ≥ 2.3.0, < 2.3.1
Update to 1.15.4; Update to 2.0.3; Update to 2.1.2; Update to 2.2.1; Update to 2.3.1
Original sources
- https://github.com/tensorflow/tensorflow/releases/tag/v2.3.1
- https://github.com/tensorflow/tensorflow/commit/390611e0d45c5793c7066110af37c8514e6a6c54
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-9mqp-7v2h-2382
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00065.html
- https://nvd.nist.gov/vuln/detail/CVE-2020-15194