p PatchFirst

CVE-2020-15213

CVE-2020-15213 · Denial of service in tensorflow-lite

This page contains facts from public vulnerability sources. Check the original advisory before updating.

In TensorFlow Lite before versions 2.2.1 and 2.3.1, models using segment sum can trigger a denial of service by causing an out of memory allocation in the implementation of segment sum. Since code uses the last element of the tensor holding them to determine the dimensionality of output tensor, attackers can use a very large value to trigger a large allocation. The issue is patched in commit 204945b19e44b57906c9344c0d00120eeeae178a and is released in TensorFlow versions 2.2.1, or 2.3.1. A potential workaround would be to add a custom `Verifier` to limit the maximum value in the segment ids tensor. This only handles the case when the segment ids are stored statically in the model, but a similar validation could be done if the segment ids are generated at runtime, between inference steps. However, if the segment ids are generated as outputs of a tensor during inference steps, then there are no possible workaround and users are advised to upgrade to patched code.

CVSS 4.0 · Medium · EPSS 0.8% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • tensorflow

    Versions
    • = 2.2.0: Affected
    • = 2.3.0: Affected

    No fix published

  • tensorflow PyPI

    Versions
    • 2.2.0
    Affected ranges
    • ECOSYSTEM: ≥ 2.2.0, < 2.2.1

    Update to 2.2.1

  • tensorflow PyPI

    Versions
    • 2.3.0
    Affected ranges
    • ECOSYSTEM: ≥ 2.3.0, < 2.3.1

    Update to 2.3.1

  • tensorflow-cpu PyPI

    Versions
    • 2.2.0
    Affected ranges
    • ECOSYSTEM: ≥ 2.2.0, < 2.2.1

    Update to 2.2.1

  • tensorflow-cpu PyPI

    Versions
    • 2.3.0
    Affected ranges
    • ECOSYSTEM: ≥ 2.3.0, < 2.3.1

    Update to 2.3.1

  • tensorflow-gpu PyPI

    Versions
    • 2.2.0
    Affected ranges
    • ECOSYSTEM: ≥ 2.2.0, < 2.2.1

    Update to 2.2.1

  • tensorflow-gpu PyPI

    Versions
    • 2.3.0
    Affected ranges
    • ECOSYSTEM: ≥ 2.3.0, < 2.3.1

    Update to 2.3.1

  • tensorflow PyPI

    Versions
    • 2.2.0
    • 2.3.0
    Affected ranges
    • GIT: < 204945b19e44b57906c9344c0d00120eeeae178a
    • ECOSYSTEM: ≥ 2.2.0, < 2.2.1 ∪ ≥ 2.3.0, < 2.3.1

    Update to 2.2.1; Update to 2.3.1

  • tensorflow-cpu PyPI

    Versions
    • 2.2.0
    • 2.3.0
    Affected ranges
    • GIT: < 204945b19e44b57906c9344c0d00120eeeae178a
    • ECOSYSTEM: ≥ 2.2.0, < 2.2.1 ∪ ≥ 2.3.0, < 2.3.1

    Update to 2.2.1; Update to 2.3.1

  • tensorflow-gpu PyPI

    Versions
    • 2.2.0
    • 2.3.0
    Affected ranges
    • GIT: < 204945b19e44b57906c9344c0d00120eeeae178a
    • ECOSYSTEM: ≥ 2.2.0, < 2.2.1 ∪ ≥ 2.3.0, < 2.3.1

    Update to 2.2.1; Update to 2.3.1

Original sources

Check your server →