p PatchFirst

CVE-2020-15242

CVE-2020-15242 · Open Redirect in Next.js

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Next.js versions >=9.5.0 and <9.5.4 are vulnerable to an Open Redirect. Specially encoded paths could be used with the trailing slash redirect to allow an open redirect to occur to an external site. In general, this redirect does not directly harm users although can allow for phishing attacks by redirecting to an attackers domain from a trusted domain. The issue is fixed in version 9.5.4.

CVSS 4.7 · Medium · EPSS 0.8% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • next.js

    Versions
    • >= 9.5.0, <9.5.4: Affected

    No fix published

  • next npm

    Affected ranges
    • SEMVER: ≥ 9.5.0, < 9.5.4

    Update to 9.5.4

Original sources

Check your server →