p PatchFirst

CVE-2020-15471

CVE-2020-15471

This page contains facts from public vulnerability sources. Check the original advisory before updating.

In nDPI through 3.2, the packet parsing code is vulnerable to a heap-based buffer over-read in ndpi_parse_packet_line_info in lib/ndpi_main.c.

CVSS 9.1 · Critical · EPSS 1.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • ndpi Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.4-1

    Update to 3.4-1

  • ndpi Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.4-1

    Update to 3.4-1

  • ndpi Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.4-1

    Update to 3.4-1

Original sources

Check your server →