CVE-2020-16092
CVE-2020-16092
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In QEMU through 5.0.0, an assertion failure can occur in the network packet processing. This issue affects the e1000e and vmxnet3 network devices. A malicious guest user/process could use this flaw to abort the QEMU process on the host, resulting in a denial of service condition in net_tx_pkt_add_raw_fragment in hw/net/net_tx_pkt.c.
CVSS 3.8 · Low · EPSS 0.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
qemu Debian:12
- Affected ranges
- ECOSYSTEM: < 1:5.1+dfsg-1
Update to 1:5.1+dfsg-1
qemu Debian:13
- Affected ranges
- ECOSYSTEM: < 1:5.1+dfsg-1
Update to 1:5.1+dfsg-1
qemu Debian:14
- Affected ranges
- ECOSYSTEM: < 1:5.1+dfsg-1
Update to 1:5.1+dfsg-1
qemu Ubuntu:18.04:LTS
- Versions
- 1:2.10+dfsg-0ubuntu3
- 1:2.10+dfsg-0ubuntu4
- 1:2.10+dfsg-0ubuntu5
- 1:2.11+dfsg-1ubuntu1
- 1:2.11+dfsg-1ubuntu2
- 1:2.11+dfsg-1ubuntu4
- 1:2.11+dfsg-1ubuntu5
- 1:2.11+dfsg-1ubuntu6
- 1:2.11+dfsg-1ubuntu7
- 1:2.11+dfsg-1ubuntu7.1
- 1:2.11+dfsg-1ubuntu7.2
- 1:2.11+dfsg-1ubuntu7.3
- 1:2.11+dfsg-1ubuntu7.4
- 1:2.11+dfsg-1ubuntu7.5
- 1:2.11+dfsg-1ubuntu7.6
- 1:2.11+dfsg-1ubuntu7.7
- 1:2.11+dfsg-1ubuntu7.8
- 1:2.11+dfsg-1ubuntu7.9
- 1:2.11+dfsg-1ubuntu7.10
- 1:2.11+dfsg-1ubuntu7.12
- 1:2.11+dfsg-1ubuntu7.13
- 1:2.11+dfsg-1ubuntu7.14
- 1:2.11+dfsg-1ubuntu7.15
- 1:2.11+dfsg-1ubuntu7.17
- 1:2.11+dfsg-1ubuntu7.18
- 1:2.11+dfsg-1ubuntu7.19
- 1:2.11+dfsg-1ubuntu7.20
- 1:2.11+dfsg-1ubuntu7.21
- 1:2.11+dfsg-1ubuntu7.22
- 1:2.11+dfsg-1ubuntu7.23
- 1:2.11+dfsg-1ubuntu7.25
- 1:2.11+dfsg-1ubuntu7.26
- 1:2.11+dfsg-1ubuntu7.27
- 1:2.11+dfsg-1ubuntu7.28
- 1:2.11+dfsg-1ubuntu7.29
- Affected ranges
- ECOSYSTEM: < 1:2.11+dfsg-1ubuntu7.31
Update to 1:2.11+dfsg-1ubuntu7.31
qemu Ubuntu:20.04:LTS
- Versions
- 1:4.0+dfsg-0ubuntu9
- 1:4.0+dfsg-0ubuntu10
- 1:4.2-1ubuntu1
- 1:4.2-1ubuntu2
- 1:4.2-3ubuntu1
- 1:4.2-3ubuntu2
- 1:4.2-3ubuntu3
- 1:4.2-3ubuntu4
- 1:4.2-3ubuntu5
- 1:4.2-3ubuntu6
- 1:4.2-3ubuntu6.1
- 1:4.2-3ubuntu6.2
- 1:4.2-3ubuntu6.3
- Affected ranges
- ECOSYSTEM: < 1:4.2-3ubuntu6.4
Update to 1:4.2-3ubuntu6.4
Original sources
- https://lists.nongnu.org/archive/html/qemu-devel/2020-07/msg07563.html
- http://www.openwall.com/lists/oss-security/2020/08/10/1
- https://security.netapp.com/advisory/ntap-20200821-0006/
- https://usn.ubuntu.com/4467-1/
- https://www.debian.org/security/2020/dsa-4760
- https://lists.debian.org/debian-lts-announce/2020/09/msg00013.html
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00024.html
- https://security.gentoo.org/glsa/202208-27
- https://nvd.nist.gov/vuln/detail/CVE-2020-16092