p PatchFirst

CVE-2020-18032

CVE-2020-18032

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Buffer Overflow in Graphviz Graph Visualization Tools from commit ID f8b9e035 and earlier allows remote attackers to execute arbitrary code or cause a denial of service (application crash) by loading a crafted file into the "lib/common/shapes.c" component.

CVSS 7.8 · High · EPSS 2.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • graphviz Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.42.2-5

    Update to 2.42.2-5

  • graphviz Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.42.2-5

    Update to 2.42.2-5

  • graphviz Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.42.2-5

    Update to 2.42.2-5

  • graphviz Ubuntu:Pro:14.04:LTS

    Versions
    • 2.26.3-15ubuntu4
    • 2.34.0-0ubuntu4
    • 2.34.0-0ubuntu5
    • 2.36.0-0ubuntu1
    • 2.36.0-0ubuntu2
    • 2.36.0-0ubuntu3
    • 2.36.0-0ubuntu3.1
    • 2.36.0-0ubuntu3.2
    Affected ranges
    • ECOSYSTEM: < 2.36.0-0ubuntu3.2+esm1

    Update to 2.36.0-0ubuntu3.2+esm1

  • graphviz Ubuntu:Pro:16.04:LTS

    Versions
    • 2.38.0-10build1
    • 2.38.0-11
    • 2.38.0-12
    • 2.38.0-12build1
    • 2.38.0-12ubuntu1
    • 2.38.0-12ubuntu2
    • 2.38.0-12ubuntu2.1
    Affected ranges
    • ECOSYSTEM: < 2.38.0-12ubuntu2.1+esm1

    Update to 2.38.0-12ubuntu2.1+esm1

  • graphviz Ubuntu:Pro:18.04:LTS

    Versions
    • 2.38.0-16ubuntu2
    • 2.38.0-18ubuntu1
    • 2.40.1-0ubuntu5
    • 2.40.1-0ubuntu6
    • 2.40.1-2
    Affected ranges
    • ECOSYSTEM: < 2.40.1-2ubuntu0.1~esm1

    Update to 2.40.1-2ubuntu0.1~esm1

  • graphviz Ubuntu:Pro:20.04:LTS

    Versions
    • 2.40.1-7build1
    • 2.40.1-7build2
    • 2.42.2-3
    • 2.42.2-3build1
    • 2.42.2-3build2
    Affected ranges
    • ECOSYSTEM: < 2.42.2-3ubuntu0.1~esm1

    Update to 2.42.2-3ubuntu0.1~esm1

Original sources

Check your server →