CVE-2020-22217
CVE-2020-22217
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Buffer overflow vulnerability in c-ares before 1_16_1 thru 1_17_0 via function ares_parse_soa_reply in ares_parse_soa_reply.c.
CVSS 5.9 · Medium · EPSS 1.0% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
c-ares Debian:12
- Affected ranges
- ECOSYSTEM: < 1.17.1-1
Update to 1.17.1-1
c-ares Debian:13
- Affected ranges
- ECOSYSTEM: < 1.17.1-1
Update to 1.17.1-1
c-ares Debian:14
- Affected ranges
- ECOSYSTEM: < 1.17.1-1
Update to 1.17.1-1
c-ares Ubuntu:Pro:16.04:LTS
- Versions
- 1.10.0-2
- 1.10.0-3
- 1.10.0-3ubuntu0.1
- 1.10.0-3ubuntu0.2
- 1.10.0-3ubuntu0.2+esm1
- 1.10.0-3ubuntu0.2+esm2
- 1.10.0-3ubuntu0.2+esm3
- Affected ranges
- ECOSYSTEM: < 1.10.0-3ubuntu0.2+esm4
Update to 1.10.0-3ubuntu0.2+esm4
c-ares Ubuntu:Pro:18.04:LTS
- Versions
- 1.13.0-2
- 1.13.0-3
- 1.14.0-1
- 1.14.0-1ubuntu0.1
- 1.14.0-1ubuntu0.2
- 1.14.0-1ubuntu0.2+esm1
- 1.14.0-1ubuntu0.2+esm2
- Affected ranges
- ECOSYSTEM: < 1.14.0-1ubuntu0.2+esm3
Update to 1.14.0-1ubuntu0.2+esm3
c-ares Ubuntu:20.04:LTS
- Versions
- 1.15.0-1build1
- 1.15.0-1ubuntu0.1
- 1.15.0-1ubuntu0.2
- 1.15.0-1ubuntu0.3
- Affected ranges
- ECOSYSTEM: < 1.15.0-1ubuntu0.4
Update to 1.15.0-1ubuntu0.4