p PatchFirst

CVE-2020-25595

CVE-2020-25595

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue was discovered in Xen through 4.14.x. The PCI passthrough code improperly uses register data. Code paths in Xen's MSI handling have been identified that act on unsanitized values read back from device hardware registers. While devices strictly compliant with PCI specifications shouldn't be able to affect these registers, experience shows that it's very common for devices to have out-of-spec "backdoor" operations that can affect the result of these reads. A not fully trusted guest may be able to crash Xen, leading to a Denial of Service (DoS) for the entire system. Privilege escalation and information leaks cannot be excluded. All versions of Xen supporting PCI passthrough are affected. Only x86 systems are vulnerable. Arm systems are not vulnerable. Only guests with passed through PCI devices may be able to leverage the vulnerability. Only systems passing through devices with out-of-spec ("backdoor") functionality can cause issues. Experience shows that such out-of-spec functionality is common; unless you have reason to believe that your device does not have such functionality, it's better to assume that it does.

CVSS 7.8 · High · EPSS 0.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • xen Debian:12

    Affected ranges
    • ECOSYSTEM: < 4.14.0+80-gd101b417b7-1

    Update to 4.14.0+80-gd101b417b7-1

  • xen Debian:13

    Affected ranges
    • ECOSYSTEM: < 4.14.0+80-gd101b417b7-1

    Update to 4.14.0+80-gd101b417b7-1

  • xen Debian:14

    Affected ranges
    • ECOSYSTEM: < 4.14.0+80-gd101b417b7-1

    Update to 4.14.0+80-gd101b417b7-1

  • xen Ubuntu:16.04:LTS

    Versions
    • 4.5.1-0ubuntu1
    • 4.5.1-0ubuntu2
    • 4.6.0-1ubuntu1
    • 4.6.0-1ubuntu2
    • 4.6.0-1ubuntu4
    • 4.6.0-1ubuntu4.1
    • 4.6.0-1ubuntu4.2
    • 4.6.0-1ubuntu4.3
    • 4.6.5-0ubuntu1
    • 4.6.5-0ubuntu1.1
    • 4.6.5-0ubuntu1.2
    • 4.6.5-0ubuntu1.4
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • xen Ubuntu:18.04:LTS

    Versions
    • 4.9.0-0ubuntu3
    • 4.9.0-0ubuntu4
    • 4.9.2-0ubuntu1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • xen Ubuntu:20.04:LTS

    Versions
    • 4.9.2-0ubuntu2
    • 4.9.2-0ubuntu6
    • 4.9.2-0ubuntu7
    • 4.11.3+24-g14b62ab3e5-1ubuntu1
    • 4.11.3+24-g14b62ab3e5-1ubuntu2
    • 4.11.3+24-g14b62ab3e5-1ubuntu2.2
    Affected ranges
    • ECOSYSTEM: < 4.11.3+24-g14b62ab3e5-1ubuntu2.3

    Update to 4.11.3+24-g14b62ab3e5-1ubuntu2.3

Original sources

Check your server →