CVE-2020-25628
CVE-2020-25628
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The filter in the tag manager required extra sanitizing to prevent a reflected XSS risk. This affects 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. Fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.
CVSS 6.1 · Medium · EPSS 1.0% · Fix available
- Published
- Updated
Affected products and versions
moodle
- Versions
- 3.9 to 3.9.1: Affected
- 3.8 to 3.8.4: Affected
- 3.7 to 3.7.7: Affected
- 3.5 to 3.5.13: Affected
- earlier unsupported versions: Affected
No fix published
moodle/moodle Packagist
- Versions
- v3.9.0
- v3.9.1
- Affected ranges
- ECOSYSTEM: ≥ 3.9.0, < 3.9.2
Update to 3.9.2
moodle/moodle Packagist
- Versions
- v3.8.0
- v3.8.1
- v3.8.2
- v3.8.3
- v3.8.4
- Affected ranges
- ECOSYSTEM: ≥ 3.8.0, < 3.8.5
Update to 3.8.5
moodle/moodle Packagist
- Versions
- v3.7.0
- v3.7.1
- v3.7.2
- v3.7.3
- v3.7.4
- v3.7.5
- v3.7.6
- v3.7.7
- Affected ranges
- ECOSYSTEM: ≥ 3.7.0, < 3.7.8
Update to 3.7.8
moodle/moodle Packagist
- Versions
- v3.5.0
- v3.5.0-beta
- v3.5.0-rc1
- v3.5.1
- v3.5.10
- v3.5.11
- v3.5.12
- v3.5.13
- v3.5.2
- v3.5.3
- v3.5.4
- v3.5.5
- v3.5.6
- v3.5.7
- v3.5.8
- v3.5.9
- Affected ranges
- ECOSYSTEM: ≥ 3.5, < 3.5.14
Update to 3.5.14
moodle Ubuntu:Pro:16.04:LTS
- Versions
- 2.7.9+dfsg-1
- 2.7.10+dfsg-1
- 2.7.11+dfsg-1
- 2.7.11+dfsg-2
- 2.7.12+dfsg-1
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
moodle Ubuntu:Pro:18.04:LTS
- Versions
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published