p PatchFirst

CVE-2020-25648

CVE-2020-25648

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A flaw was found in the way NSS handled CCS (ChangeCipherSpec) messages in TLS 1.3. This flaw allows a remote attacker to send multiple CCS messages, causing a denial of service for servers compiled with the NSS library. The highest threat from this vulnerability is to system availability. This flaw affects NSS versions before 3.58.

CVSS 7.5 · High · EPSS 3.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • nss

    Versions
    • nss versions before 3.58: Affected

    No fix published

  • nss Debian:12

    Affected ranges
    • ECOSYSTEM: < 2:3.58-1

    Update to 2:3.58-1

  • nss Debian:13

    Affected ranges
    • ECOSYSTEM: < 2:3.58-1

    Update to 2:3.58-1

  • nss Debian:14

    Affected ranges
    • ECOSYSTEM: < 2:3.58-1

    Update to 2:3.58-1

  • nss Ubuntu:18.04:LTS

    Versions
    • 2:3.32-1ubuntu3
    • 2:3.34-1ubuntu1
    • 2:3.35-2ubuntu2
    • 2:3.35-2ubuntu2.1
    • 2:3.35-2ubuntu2.2
    • 2:3.35-2ubuntu2.3
    • 2:3.35-2ubuntu2.5
    • 2:3.35-2ubuntu2.6
    • 2:3.35-2ubuntu2.7
    • 2:3.35-2ubuntu2.8
    • 2:3.35-2ubuntu2.9
    • 2:3.35-2ubuntu2.11
    • 2:3.35-2ubuntu2.12
    • 2:3.35-2ubuntu2.13
    Affected ranges
    • ECOSYSTEM: < 2:3.35-2ubuntu2.14

    Update to 2:3.35-2ubuntu2.14

  • nss Ubuntu:20.04:LTS

    Versions
    • 2:3.45-1ubuntu2
    • 2:3.47-1ubuntu1
    • 2:3.47-1ubuntu2
    • 2:3.48-1ubuntu1
    • 2:3.49.1-1ubuntu1
    • 2:3.49.1-1ubuntu1.1
    • 2:3.49.1-1ubuntu1.2
    • 2:3.49.1-1ubuntu1.4
    • 2:3.49.1-1ubuntu1.5
    • 2:3.49.1-1ubuntu1.6
    Affected ranges
    • ECOSYSTEM: < 2:3.49.1-1ubuntu1.7

    Update to 2:3.49.1-1ubuntu1.7

Original sources

Check your server →