CVE-2020-25817
CVE-2020-25817
This page contains facts from public vulnerability sources. Check the original advisory before updating.
SilverStripe through 4.6.0-rc1 has an XXE Vulnerability in CSSContentParser. A developer utility meant for parsing HTML within unit tests can be vulnerable to XML External Entity (XXE) attacks. When this developer utility is misused for purposes involving external or user submitted data in custom project code, it can lead to vulnerabilities such as XSS on HTML output rendered through this custom code. This is now mitigated by disabling external entities during parsing. (The correct CVE ID year is 2020 [CVE-2020-25817, not CVE-2021-25817]).
CVSS 4.8 · Medium · EPSS 0.8% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
silverstripe/framework Packagist
- Versions
- 4.0.0
- 4.0.1
- 4.0.1-rc1
- 4.0.2
- 4.0.3
- 4.0.4
- 4.0.5
- 4.0.6
- 4.0.7
- 4.1.0
- 4.1.0-rc1
- 4.1.0-rc2
- 4.1.1
- 4.1.2
- 4.1.3
- 4.1.4
- 4.1.5
- 4.2.0
- 4.2.0-beta1
- 4.2.1
- 4.2.2
- 4.2.3
- 4.2.4
- 4.2.5
- 4.3.0
- 4.3.0-rc1
- 4.3.1
- 4.3.2
- 4.3.3
- 4.3.4
- 4.3.5
- 4.4.0
- 4.4.0-rc1
- 4.4.1
- 4.4.2
- 4.4.3
- 4.4.4
- 4.4.5
- 4.4.6
- 4.4.7
- 4.5.0
- 4.5.0-alpha1
- 4.5.0-rc1
- 4.5.0-rc2
- 4.5.1
- 4.5.2
- 4.5.3
- 4.5.4
- 4.6.0
- 4.6.0-beta1
- 4.6.0-rc1
- 4.6.1
- 4.6.2
- 4.7.0
- 4.7.0-beta1
- 4.7.0-rc1
- 4.7.1
- 4.7.2
- 4.7.3
- Affected ranges
- ECOSYSTEM: ≥ 4.0.0, < 4.7.4
Update to 4.7.4