p PatchFirst

CVE-2020-2655

CVE-2020-2655

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Vulnerability in the Java SE product of Oracle Java SE (component: JSSE). Supported versions that are affected are Java SE: 11.0.5 and 13.0.1. Difficult to exploit vulnerability allows unauthenticated attacker with network access via HTTPS to compromise Java SE. Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of Java SE accessible data as well as unauthorized read access to a subset of Java SE accessible data. Note: This vulnerability applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets (in Java SE 8), that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. This vulnerability can also be exploited by using APIs in the specified Component, e.g., through a web service which supplies data to the APIs. CVSS 3.0 Base Score 4.8 (Confidentiality and Integrity impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N).

CVSS 4.8 · Medium · EPSS 3.6% · Fix available

Published
Updated

Stack: system · applications

Affected products and versions

  • java

    Versions
    • Java SE: 11.0.5, 13.0.1: Affected

    No fix published

  • openjdk-11 Debian:11

    Affected ranges
    • ECOSYSTEM: < 11.0.6+10-1

    Update to 11.0.6+10-1

  • openjdk-lts Ubuntu:18.04:LTS

    Versions
    • 9.0.4+12-2ubuntu4
    • 9.0.4+12-4ubuntu1
    • 10~46-4ubuntu1
    • 10~46-5ubuntu1
    • 10.0.1+10-1ubuntu2
    • 10.0.1+10-3ubuntu1
    • 10.0.2+13-1ubuntu0.18.04.1
    • 10.0.2+13-1ubuntu0.18.04.2
    • 10.0.2+13-1ubuntu0.18.04.3
    • 10.0.2+13-1ubuntu0.18.04.4
    • 11.0.2+9-3ubuntu1~18.04.3
    • 11.0.3+7-1ubuntu2~18.04.1
    • 11.0.4+11-1ubuntu2~18.04.3
    • 11.0.5+10-0ubuntu1.1~18.04
    Affected ranges
    • ECOSYSTEM: < 11.0.6+10-1ubuntu1~18.04.1

    Update to 11.0.6+10-1ubuntu1~18.04.1

  • openjdk-lts Ubuntu:20.04:LTS

    Versions
    • 11.0.5+10-0ubuntu1
    • 11.0.5+10-2ubuntu1
    Affected ranges
    • ECOSYSTEM: < 11.0.6+10-1ubuntu1

    Update to 11.0.6+10-1ubuntu1

Original sources

Check your server →